HIER(7) BSD Miscellaneous Information Manual HIER(7)NAME
hier -- layout of filesystems
A historical sketch of the filesystem hierarchy. The modern OS X filesystem is documented in the ``File System Programming Guide'' available
on Apple Developer.
/ root directory of the filesystem
/bin/ user utilities fundamental to both single-user and multi-user environments
/dev/ block and character device files
fd/ file descriptor files; see fd(4)
/etc/ system configuration files and scripts
/mach_kernel kernel executable (the operating system loaded into memory at boot time).
/sbin/ system programs and administration utilities fundamental to both single-user and multi-user environments
/tmp/ temporary files
/usr/ contains the majority of user utilities and applications
bin/ common utilities, programming tools, and applications
include/ standard C include files
arpa/ C include files for Internet service protocols
hfs/ C include files for HFS
machine/ machine specific C include files
net/ misc network C include files
netinet/ C include files for Internet standard protocols; see inet(4)
nfs/ C include files for NFS (Network File System)
objc/ C include files for Objective-C
protocols/ C include files for Berkeley service protocols
sys/ system C include files (kernel data structures)
ufs/ C include files for UFS
lib/ archive libraries
libexec/ system daemons & system utilities (executed by other programs)
local/ executables, libraries, etc. not included by the basic operating system
sbin/ system daemons & system utilities (executed by users)
share/ architecture-independent data files
calendar/ a variety of pre-fab calendar files; see calendar(1)
dict/ word lists; see look(1)
web2 words from Webster's 2nd International
words common words
man/ manual pages
misc/ misc system-wide ascii text files
mk/ templates for make; see make(1)
skel/ example . (dot) files for new accounts
tabset/ tab description files for a variety of terminals; used in the termcap file; see termcap(5)
zoneinfo/ timezone configuration information; see tzfile(5)
/var/ multi-purpose log, temporary, transient, and spool files
at/ timed command scheduling files; see at(1)
backups/ misc. backup files
db/ misc. automatically generated system-specific database files
log/ misc. system log files
mail/ user mailbox files
run/ system information files describing various info about system since it was booted
utmpx database of current users; see utmpx(5)
rwho/ rwho data files; see rwhod(8), rwho(1), and ruptime(1)
spool/ misc. printer and mail system spooling directories
mqueue/ undelivered mail queue; see sendmail(8)
tmp/ temporary files that are kept between system reboots
folders/ per-user temporary files and caches
SEE ALSO ls(1), apropos(1), whatis(1), whereis(1), finger(1), which(1), find(1), grep(1), fsck(8)HISTORY
A hier manual page appeared in Version 7 AT&T UNIX.
BSD July 23, 2007 BSD
Check Out this Related Man Page
HIER(7) Linux Programmer's Manual HIER(7)NAME
hier - description of the file system hierarchy
A typical Linux system has, among others, the following directories:
/ This is the root directory. This is where the whole tree starts.
/bin This directory contains executable programs which are needed in single user mode and to bring the system up or repair it.
/boot Contains static files for the boot loader. This directory only holds the files which are needed during the boot process. The map
installer and configuration files should go to /sbin and /etc.
/dev Special or device files, which refer to physical devices. See mknod(1).
/etc Contains configuration files which are local to the machine. Some larger software packages, like X11, can have their own subdirec-
tories below /etc. Site-wide configuration files may be placed here or in /usr/etc. Nevertheless, programs should always look for
these files in /etc and you may have links for these files to /usr/etc.
Host-specific configuration files for add-on applications installed in /opt.
This directory contains the configuration files for SGML and XML (optional).
When a new user account is created, files from this directory are usually copied into the user's home directory.
Configuration files for the X11 window system (optional).
/home On machines with home directories for users, these are usually beneath this directory, directly or not. The structure of this
directory depends on local administration decisions.
/lib This directory should hold those shared libraries that are necessary to boot the system and to run the commands in the root file
/media This directory contains mount points for removable media such as CD and DVD disks or USB sticks.
/mnt This directory is a mount point for a temporarily mounted file system. In some distributions, /mnt contains subdirectories intended
to be used as mount points for several temporary file systems.
/opt This directory should contain add-on packages that contain static files.
/proc This is a mount point for the proc file system, which provides information about running processes and the kernel. This pseudo-file
system is described in more detail in proc(5).
/root This directory is usually the home directory for the root user (optional).
/sbin Like /bin, this directory holds commands needed to boot the system, but which are usually not executed by normal users.
/srv This directory contains site-specific data that is served by this system.
/tmp This directory contains temporary files which may be deleted with no notice, such as by a regular job or at system boot up.
/usr This directory is usually mounted from a separate partition. It should hold only sharable, read-only data, so that it can be
mounted by various machines running Linux.
The X-Window system, version 11 release 6 (optional).
Binaries which belong to the X-Window system; often, there is a symbolic link from the more traditional /usr/bin/X11 to here.
Data files associated with the X-Window system.
These contain miscellaneous files needed to run X; Often, there is a symbolic link from /usr/lib/X11 to this directory.
Contains include files needed for compiling programs using the X11 window system. Often, there is a symbolic link from
/usr/include/X11 to this directory.
This is the primary directory for executable programs. Most programs executed by normal users which are not needed for booting or
for repairing the system and which are not installed locally should be placed in this directory.
is the traditional place to look for X11 executables; on Linux, it usually is a symbolic link to /usr/X11R6/bin.
Replaced by /usr/share/dict.
Replaced by /usr/share/doc.
Site-wide configuration files to be shared between several machines may be stored in this directory. However, commands should
always reference those files using the /etc directory. Links from files in /etc should point to the appropriate files in /usr/etc.
Binaries for games and educational programs (optional).
Include files for the C compiler.
Include files for the C compiler and the X-Window system. This is usually a symbolic link to /usr/X11R6/include/X11.
Include files which declare some assembler functions. This used to be a symbolic link to /usr/src/linux/include/asm.
This contains information which may change from system release to system release and used to be a symbolic link to
/usr/src/linux/include/linux to get at operating system specific information.
(Note that one should have include files there that work correctly with the current libc and in user space. However, Linux kernel
source is not designed to be used with user programs and does not know anything about the libc you are using. It is very likely
that things will break if you let /usr/include/asm and /usr/include/linux point at a random kernel tree. Debian systems don't do
this and use headers from a known good kernel version, provided in the libc*-dev package.)
Include files to use with the GNU C++ compiler.
Object libraries, including dynamic libraries, plus some executables which usually are not invoked directly. More complicated pro-
grams may have whole subdirectories there.
The usual place for data files associated with X programs, and configuration files for the X system itself. On Linux, it usually is
a symbolic link to /usr/X11R6/lib/X11.
contains executables and include files for the GNU C compiler, gcc(1).
Files for the GNU groff document formatting system.
Files for uucp(1).
This is where programs which are local to the site typically go.
Binaries for programs local to the site.
Configuration files associated with locally installed programs.
Binaries for locally installed games.
Files associated with locally installed programs.
Header files for the local C compiler.
Info pages associated with locally installed programs.
Man pages associated with locally installed programs.
Locally installed programs for system administration.
Local application data that can be shared among different architectures of the same OS.
Source code for locally installed software.
Replaced by /usr/share/man.
This directory contains program binaries for system administration which are not essential for the boot process, for mounting /usr,
or for system repair.
This directory contains subdirectories with specific application data, that can be shared among different architectures of the same
OS. Often one finds stuff here that used to live in /usr/doc or /usr/lib or /usr/man.
Contains the word lists used by spell checkers.
Documentation about installed programs.
Static data files for games in /usr/games.
Info pages go here.
Locale information goes here.
Manual pages go here in subdirectories according to the man page sections.
These directories contain manual pages for the specific locale in source code form. Systems which use a unique language and code
set for all manual pages may omit the <locale> substring.
Miscellaneous data that can be shared among different architectures of the same OS.
The message catalogs for native language support go here.
Files for SGML and XML.
The database for terminfo.
Troff macros that are not distributed with groff.
Files for timezone information.
Source files for different parts of the system, included with some packages for reference purposes. Don't work here with your own
projects, as files below /usr should be read-only except when installing software.
This was the traditional place for the kernel source. Some distributions put here the source for the default kernel they ship. You
should probably use another directory when building your own kernel.
Obsolete. This should be a link to /var/tmp. This link is present only for compatibility reasons and shouldn't be used.
/var This directory contains files which may change in size, such as spool and log files.
This directory is superseded by /var/log and should be a symbolic link to /var/log.
Reserved for historical reasons.
Data cached for programs.
/var/catman/cat[1-9] or /var/cache/man/cat[1-9]
These directories contain preformatted manual pages according to their man page section. (The use of preformatted manual pages is
Reserved for historical reasons.
Variable state information for programs.
Variable data for /usr/local.
Lock files are placed in this directory. The naming convention for device lock files is LCK..<device> where <device> is the
device's name in the file system. The format used is that of HDU UUCP lock files, that is, lock files contain a PID as a 10-byte
ASCII decimal number, followed by a newline character.
Miscellaneous log files.
Variable data for /opt.
Users' mailboxes. Replaces /var/spool/mail.
Reserved for historical reasons.
Reserved for historical reasons.
Run-time variable files, like files holding process identifiers (PIDs) and logged user information (utmp). Files in this directory
are usually cleared when the system boots.
Spooled (or queued) files for various programs.
Spooled jobs for at(1).
Spooled jobs for cron(8).
Spooled files for printing.
Replaced by /var/mail.
Queued outgoing mail.
Spool directory for news.
Spooled files for rwhod(8).
Spooled files for the smail(1) mail delivery program.
Spooled files for uucp(1).
Like /tmp, this directory holds temporary files stored for an unspecified duration.
Database files for NIS.
The Filesystem Hierarchy Standard, Version 2.2 <http://www.pathname.com/fhs/>.
This list is not exhaustive; different systems may be configured differently.
SEE ALSO find(1), ln(1), proc(5), mount(8)
The Filesystem Hierarchy Standard
This page is part of release 3.44 of the Linux man-pages project. A description of the project, and information about reporting bugs, can
be found at http://www.kernel.org/doc/man-pages/.
Linux 2012-08-05 HIER(7)