UTMPX(5) BSD File Formats Manual UTMPX(5)NAME
utmpx -- user accounting database
In contrast to utmp and wtmp, the extended databases in utmpx and wtmpx reserve more space for logging hostnames, and also information on a
process' ID, termination signal and exit status.
The <utmpx.h> header defines the structures and functions for logging user. Currently logged in users are tracked in /var/run/utmpx. The
interface to the utmpx file is described in endutxent(3). The file is not automatically created if they do not exist; it must be created
Traditionally, separate files would be used to store the running log of the logins and logouts (wtmpx), and the last login of each user
(lastlogx). With the availability of the Apple system log facility asl(3), these separate files can be replace with log entries, which are
automatically generated when utmpx entries are written. The API to access the logins and logouts is described in endutxent_wtmp(3) while the
last login info is accessible with getlastlogx(3).
For compatibility, changes to utmpx are reflected in utmp(3) (in the utmp, wtmp and lastlog files), but not the other way around.
/var/run/utmpx The utmpx file.
SEE ALSO asl(3), endutxent(3), endutxent_wtmp(3), getlastlogx(3), utmp(5)BSD January 31, 2007 BSD
Check Out this Related Man Page
utmpx(4) File Formats utmpx(4)NAME
utmpx, wtmpx - utmpx and wtmpx database entry formats
The utmpx and wtmpx files are extended database files that have superseded the obsolete utmp and wtmp database files.
The utmpx database contains user access and accounting information for commands such as who(1), write(1), and login(1). The wtmpx database
contains the history of user access and accounting information for the utmpx database.
Applications should not access these databases directly, but should use the functions described on the getutxent(3C) manual page to inter-
act with the utmpx and wtmpx databases to ensure that they are maintained consistently.
/var/adm/utmpx user access and adminstration information
/var/adm/wtmpx history of user access and adminstrative information
SEE ALSO getutxent(3C), wait(3C), wait.h(3HEAD)SunOS 5.11 6 Mar 2008 utmpx(4)
:confused: I receive the following error message when I try to logon to my Solaris 2.6 system;
"No utmpx entry. You must exec "login" from lowest level "shell" "
What does it mean ? I can't logon to the system at the moment!
Any help appreciated.
Regards (3 Replies)
I am wanting to enable logging of all ftp sessions on my Solaris 8 host. I want to at least log all ftp logins and if possible any commands that the user executes.
I have tried various settings in syslog.conf then rereading syslogd but logging still does not happen.
I have... (1 Reply)
Hi all, I'm having the following problem and wondered if anyone here could help?
I'm using a network at work which is running RH9 on all machines (I only have user access), when I log in to one of the machines in the computer cluster RH informs me I am already logged in elsewhere and mozilla... (2 Replies)
I was wondering if anyone can tell me how to log back in to unix after logging out. I have a MBPro. If I don't have the window close after exiting, then there is the phrase 'process completed' in brackets with a blinking cursor, but I can't type anything in.
Is it also possible to start the... (4 Replies)