usb_string_descr(9s) [opensolaris man page]
usb_string_descr(9S) Data Structures for Drivers usb_string_descr(9S) NAME
usb_string_descr - USB string descriptor SYNOPSIS
#include <sys/usb/usba.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) DESCRIPTION
The usb_string_descr_t string descriptor defines the attributes of a string, including size and Unicode language ID. Other USB descriptors may have string descriptor index fields which refer to specific string descriptors retrieved as part of a device's configuration. Please refer to Section 9.6.7 of the USB 2.0 specification. The USB 2.0 specification is available at www.usb.org. A string descriptor has the following fields: uint8_t bLength Size of this descriptor, in bytes. uint8_t bDescriptorType Set to USB_DESCR_TYPE_STRING. uint16_t bString[1]; Variable length Unicode encoded string. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Committed | +-----------------------------+-----------------------------+ |Availability |SUNWusbu | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), usb_get_alt_if(9F), usb_get_cfg(9F), usb_get_dev_data(9F), usb_get_string_descr(9F), usb_parse_data(9F), usb_ctrl_request(9S) SunOS 5.11 5 Jan 2004 usb_string_descr(9S)
Check Out this Related Man Page
usb_dev_qlf_descr(9S) Data Structures for Drivers usb_dev_qlf_descr(9S) NAME
usb_dev_qlf_descr - USB device qualifier descriptor SYNOPSIS
#include <sys/usb/usba.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) DESCRIPTION
The device qualifier descriptor usb_dev_qlf_descr_t defines how fields of a high speed device's device descriptor would look if that device is run at a different speed. If a high-speed device is running currently at full/high speed, fields of this descriptor reflect how device descriptor fields would look if speed was changed to high/full. Please refer to section 9.6.2 of the USB 2.0 specification. The USB 2.0 specification is available at www.usb.org. A device descriptor contains the following fields: uint8_t bLength Size of this descriptor. uint8_t bDescriptorType Set to USB_DESCR_TYPE_DEV_QLF. uint16_t bcdUSB USB specification release number in binary coded decimal. uint8_t bDeviceClass Device class code. (See usb_dev_descr(9s).) uint8_t bDeviceSubClass Device subclass code.(See USB 2.0 specification of applicable device class for information.) uint8_t bDeviceProtocol Protocol code.(See USB 2.0 specification of applicable device class for information.) uint8_t bMaxPacketSize0 Maximum packet size of endpoint 0. uint8_t bNumConfigurations Number of available configurations. uint8_t bReserved Reserved. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Committed | +-----------------------------+-----------------------------+ |Availability |SUNWusbu | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), usb_get_alt_if(9F), usb_get_cfg(9F), usb_get_dev_data(9F), usb_get_string_descr(9F). usb_parse_data(9F), usb_ctrl_request(9S), usb_cfg_descr(9S), usb_dev_descr(9S), usb_ep_descr(9S), usb_if_descr(9S), usb_other_speed_cfg_descr(9S), usb_string_descr(9S) SunOS 5.11 5 Jan 2004 usb_dev_qlf_descr(9S)