Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

iovec(9s) [opensolaris man page]

iovec(9S)						    Data Structures for Drivers 						 iovec(9S)

NAME
iovec - data storage structure for I/O using uio SYNOPSIS
#include <sys/uio.h> INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). DESCRIPTION
An iovec structure describes a data storage area for transfer in a uio(9S) structure. Conceptually, it can be thought of as a base address and length specification. STRUCTURE MEMBERS
caddr_t iov_base; /* base address of the data storage area */ /* represented by the iovec structure */ int iov_len; /* size of the data storage area in bytes */ SEE ALSO
uio(9S) Writing Device Drivers SunOS 5.11 11 Apr 1991 iovec(9S)

Check Out this Related Man Page

uiomove(9F)						   Kernel Functions for Drivers 					       uiomove(9F)

NAME
uiomove - copy kernel data using uio structure SYNOPSIS
#include <sys/types.h> #include <sys/uio.h> int uiomove(caddr_t address, size_t nbytes, enum uio_rw rwflag, uio_t *uio_p); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
address Source/destination kernel address of the copy. nbytes Number of bytes to copy. rwflag Flag indicating read or write operation. Possible values are UIO_READ and UIO_WRITE. uio_p Pointer to the uio structure for the copy. DESCRIPTION
The uiomove() function copies nbytes of data to or from the space defined by the uio structure (described in uio(9S)) and the driver. The uio_segflg member of the uio(9S) structure determines the type of space to or from which the transfer is being made. If it is set to UIO_SYSSPACE, the data transfer is between addresses in the kernel. If it is set to UIO_USERSPACE, the transfer is between a user program and kernel space. rwflag indicates the direction of the transfer. If UIO_READ is set, the data will be transferred from address to the buffer(s) described by uio_p. If UIO_WRITE is set, the data will be transferred from the buffer(s) described by uio_p to address. In addition to moving the data, uiomove() adds the number of bytes moved to the iov_base member of the iovec(9S) structure, decreases the iov_len member, increases the uio_offset member of the uio(9S) structure, and decreases the uio_resid member. This function automatically handles page faults. nbytes does not have to be word-aligned. RETURN VALUES
uiomove() returns 0 upon success or EFAULT on failure. CONTEXT
User context only, if uio_segflg is set to UIO_USERSPACE. User or interrupt context, if uio_segflg is set to UIO_SYSSPACE. SEE ALSO
ureadc(9F), uwritec(9F), iovec(9S), uio(9S) Writing Device Drivers WARNINGS
If uio_segflg is set to UIO_SYSSPACE and address is selected from user space, the system may panic. SunOS 5.10 7 Feb 2003 uiomove(9F)
Man Page

7 More Discussions You Might Find Interesting

1. Programming

i want to pass the connect fd to child process,how can i do ti?

i write a function using to pass the socket connected fd to child process in the sco unix open server 5.0.5,but in fact i execute the program calling the fuction,system report send the fd error: Jul 12 12:15 send_fd.c: send_fd sendmsg to sd error how can i solve the problem ,please help me!!!... (6 Replies)
Discussion started by: hit
6 Replies

2. HP-UX

fd passing between Independent processes using unix domain sockets

Hi, I am having some error handling issues with and fd passed between Independent processes using unix domain sockets (On HPUX). Here is the scnerio ================= Step 1: TPC/Client (connect()) ---Connects to ------TCP/Server(Gateway) (server gets fd) Step 2: ... (2 Replies)
Discussion started by: Debasisb2002
2 Replies

3. Programming

Network Code

Hi, This has been bugging me all day, I'm trying to get this code to send an ipv6 destination options header to any client that connects to it. I keep getting "Error returned from sendmsg" which is my error checking on the sendmsg function but I don't know why. Any Ideas? #include... (0 Replies)
Discussion started by: perleo
0 Replies

4. UNIX for Advanced & Expert Users

Why cannot only the "rtl8139_rx" function be setted breakpoint on whereas the others can?

Dear all: (gdb) add-symbol-file /home/likunlun/rtl8139_driver.ko 0xf80e5000 -s .bss 0xf80e72d4 -s .data 0xf80e70e0 add symbol table from file "/home/likunlun/rtl8139_driver.ko" at .text_addr = 0xf80e5000 .bss_addr = 0xf80e72d4 .data_addr = 0xf80e70e0 (y or n) y Reading symbols... (6 Replies)
Discussion started by: liklstar
6 Replies

5. Linux

TuxOnIce stalls 3 times before resuming

I am having trouble resuming from hibernation using TuxOnIce method. The thing works, but in a very strange manner. Here's how it looks: 1. Computer boots and finds resume image and starts resume. It reads image from disk (takes ~10 seconds) Reading kernel & process data... Atomic restore.... (8 Replies)
Discussion started by: lockheed
8 Replies

6. Programming

Problem with Mux channel legacy code.

I been trying to sort this error for some time now and am unable to find out whats causing it, I added the source files for the mux channel code maybe some one can see what going on something am missing. Errors: mpreq_mux#000R2: MPMuxOpen: Unable to create low-level I/O channel.... (6 Replies)
Discussion started by: Wpgn
6 Replies

7. UNIX for Beginners Questions & Answers

NTP synchronised problem in our Centos 7.6 node

Someone, please help on this issue:- Note : for security reason i didn't mention hostnames and ips. ============================================================================== # ntpstat unsynchronised polling server every 1024 s Ntpstat showing unsynchronised. ... (29 Replies)
Discussion started by: shanmugaraj
29 Replies