Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

hook_t(9s) [opensolaris man page]

hook_t(9S)						    Data Structures for Drivers 						hook_t(9S)

NAME
hook_t - callback structure for subscribing to netinfo events SYNOPSIS
#include <sys/hook.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). DESCRIPTION
The hook_t data structure defines a callback that is to be inserted into a networking event. This data structure must be allocated with a call to hook_alloc() and released with a call to hook_free(). STRUCTURE MEMBERS
hook_func_t h_func; /* callback function to invoke */ char *h_name; /* unique name given to the hook */ int h_flags; hook_hint_t h_hint; /* insertion hint type */ uintptr_t h_hintvalue; /* used with h_hint */ void *h_arg; /* value to pass into h_func */ typedef int (*hook_func_t)(net_event_t token, hook_data_t info, void *); HINT TYPES Hook hints are hints that are used at the time of insertion and are not rules that enforce where a hook lives for its entire lifetime on an event. The valid values for the h_hint field are: HH_NONE Insert the hook wherever convenient. HH_FIRST Place the hook first on the list of hooks. HH_LAST Place the hook last on the list of hooks. HH_BEFORE Place the hook before another hook on the list of hooks. The value in h_hintvalue must be a pointer to the name of another hook. HH_AFTER Place the hook after another hook on the list of hooks. The value in h_hintvalue must be a pointer to the name of another hook. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
netinfo(9F) SunOS 5.11 1 May 2008 hook_t(9S)

Check Out this Related Man Page

hook_alloc(9F)						   Kernel Functions for Drivers 					    hook_alloc(9F)

NAME
hook_alloc - allocate a hook_t data structure SYNOPSIS
#include <sys/hook.h> hook_t *hook_alloc(const int version); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
version must always be the symbol HOOK_VERSION. DESCRIPTION
The hook_alloc() function allocates a hook_t structure, returning a pointer for the caller to use. RETURN VALUES
Upon success, hook_alloc() returns a pointer to the allocated hook_t structure. On failure, hook_alloc() returns a NULL pointer. CONTEXT
The hook_alloc() function may be called from user or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
hook_free(9F), hook_t(9S) SunOS 5.11 1 May 2008 hook_alloc(9F)
Man Page

6 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Replacement for netinfo

We are getting ready to migrate away from our netinfo server with is old Open Step. We were thinking of starting to use LDAP for all account creations, passwords... Does anyone have any pros or cons against this or what you are using? Thanks for the help. (0 Replies)
Discussion started by: rickyt00
0 Replies

2. Programming

How to hook file changes?

hello, Im trying to create some kind of a file change hook on unix machines (should be generic if possible). Do any of you know how can i write some code that will trigger whenever a file is being modified and then will approve the modifications, or throw an exception if the new content of... (2 Replies)
Discussion started by: ErezB
2 Replies

3. HP-UX

Hitachi arrays to HP-UX 11.11

We have 2 servers (L1000 and rp7410) running 11.11. We would like to hook them up to either a Hitatchi AMS 2500 or Hitachi USPV via fiber channel. I need to what drivers I need for this and if it will work. Oh, they are using HP Tachyon XL2 Fiber Channel Mass Storage Adapters. Thanks, Bill (1 Reply)
Discussion started by: wsmcelroy
1 Replies

4. Linux

Howto compile my own module into the kernel

Hi there, I'm currently writing a program/module which makes use of the Linux Security Modules (LSM), which provide hooks for some security . The bad thing about it is: The function to set the hook to the LSM is not exported. That means, I can't just write a loadable kernel module, but have to... (3 Replies)
Discussion started by: disaster
3 Replies

5. What is on Your Mind?

Place Your Bits! - Who Will Win The Voice Season 3

New Event for Fans of The Voice Who Will Win The Voice Season 3 Place Your Bits! Wikipedia Reference Page (0 Replies)
Discussion started by: Neo
0 Replies

6. What is on Your Mind?

Place your bits - Who will be crowned English Premier League champions for the 2013-14 Season

Hi All, UPDATE: This has been cancelled. No more Event Prediction. Place your bits here before 30th March 2014. Who will be crowned English Premier League champions for the 2013-14 Season Tottenham Hotspur Manchester City Chelsea Liverpool Arsenal Everton Manchester United... (0 Replies)
Discussion started by: ni2
0 Replies