Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

hook_t(9s) [opensolaris man page]

hook_t(9S)						    Data Structures for Drivers 						hook_t(9S)

NAME
hook_t - callback structure for subscribing to netinfo events SYNOPSIS
#include <sys/hook.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). DESCRIPTION
The hook_t data structure defines a callback that is to be inserted into a networking event. This data structure must be allocated with a call to hook_alloc() and released with a call to hook_free(). STRUCTURE MEMBERS
hook_func_t h_func; /* callback function to invoke */ char *h_name; /* unique name given to the hook */ int h_flags; hook_hint_t h_hint; /* insertion hint type */ uintptr_t h_hintvalue; /* used with h_hint */ void *h_arg; /* value to pass into h_func */ typedef int (*hook_func_t)(net_event_t token, hook_data_t info, void *); HINT TYPES Hook hints are hints that are used at the time of insertion and are not rules that enforce where a hook lives for its entire lifetime on an event. The valid values for the h_hint field are: HH_NONE Insert the hook wherever convenient. HH_FIRST Place the hook first on the list of hooks. HH_LAST Place the hook last on the list of hooks. HH_BEFORE Place the hook before another hook on the list of hooks. The value in h_hintvalue must be a pointer to the name of another hook. HH_AFTER Place the hook after another hook on the list of hooks. The value in h_hintvalue must be a pointer to the name of another hook. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
netinfo(9F) SunOS 5.11 1 May 2008 hook_t(9S)

Check Out this Related Man Page

SHUTDOWNHOOK_ESTABLISH(9)				   BSD Kernel Developer's Manual				 SHUTDOWNHOOK_ESTABLISH(9)

NAME
shutdownhook_establish, shutdownhook_disestablish -- add or remove a shutdown hook SYNOPSIS
void * shutdownhook_establish(void (*fn)(void *), void *arg); void shutdownhook_disestablish(void *cookie); DESCRIPTION
The shutdownhook_establish API is deprecated. The shutdownhook_establish() function adds fn to the list of hooks invoked by doshutdownhooks(9) at shutdown. When invoked, the hook func- tion fn will be passed arg as its only argument. The shutdownhook_disestablish() function removes the hook described by the opaque pointer cookie from the list of hooks to be invoked at shutdown. If cookie is invalid, the result of shutdownhook_disestablish() is undefined. Shutdown hooks should be used to perform one-time activities that must happen immediately before the kernel exits. Because of the environ- ment in which they are run, shutdown hooks cannot rely on many system services (including file systems, and timeouts and other interrupt- driven services), or even basic system integrity (because the system could be rebooting after a crash). RETURN VALUES
If successful, shutdownhook_establish() returns an opaque pointer describing the newly-established shutdown hook. Otherwise, it returns NULL. EXAMPLES
It may be appropriate to use a shutdown hook to disable a device that does direct memory access, so that the device will not try to access memory while the system is rebooting. It may be appropriate to use a shutdown hook to inform watchdog timer hardware that the operating system is no longer running. SEE ALSO
doshutdownhooks(9) BUGS
The names are clumsy, at best. BSD
May 14, 2009 BSD
Man Page

6 More Discussions You Might Find Interesting

1. UNIX for Dummies Questions & Answers

Replacement for netinfo

We are getting ready to migrate away from our netinfo server with is old Open Step. We were thinking of starting to use LDAP for all account creations, passwords... Does anyone have any pros or cons against this or what you are using? Thanks for the help. (0 Replies)
Discussion started by: rickyt00
0 Replies

2. Programming

How to hook file changes?

hello, Im trying to create some kind of a file change hook on unix machines (should be generic if possible). Do any of you know how can i write some code that will trigger whenever a file is being modified and then will approve the modifications, or throw an exception if the new content of... (2 Replies)
Discussion started by: ErezB
2 Replies

3. HP-UX

Hitachi arrays to HP-UX 11.11

We have 2 servers (L1000 and rp7410) running 11.11. We would like to hook them up to either a Hitatchi AMS 2500 or Hitachi USPV via fiber channel. I need to what drivers I need for this and if it will work. Oh, they are using HP Tachyon XL2 Fiber Channel Mass Storage Adapters. Thanks, Bill (1 Reply)
Discussion started by: wsmcelroy
1 Replies

4. Linux

Howto compile my own module into the kernel

Hi there, I'm currently writing a program/module which makes use of the Linux Security Modules (LSM), which provide hooks for some security . The bad thing about it is: The function to set the hook to the LSM is not exported. That means, I can't just write a loadable kernel module, but have to... (3 Replies)
Discussion started by: disaster
3 Replies

5. What is on Your Mind?

Place Your Bits! - Who Will Win The Voice Season 3

New Event for Fans of The Voice Who Will Win The Voice Season 3 Place Your Bits! Wikipedia Reference Page (0 Replies)
Discussion started by: Neo
0 Replies

6. What is on Your Mind?

Place your bits - Who will be crowned English Premier League champions for the 2013-14 Season

Hi All, UPDATE: This has been cancelled. No more Event Prediction. Place your bits here before 30th March 2014. Who will be crowned English Premier League champions for the 2013-14 Season Tottenham Hotspur Manchester City Chelsea Liverpool Arsenal Everton Manchester United... (0 Replies)
Discussion started by: ni2
0 Replies