Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

hook_nic_event(9s) [opensolaris man page]

hook_nic_event(9S)					    Data Structures for Drivers 					hook_nic_event(9S)

NAME
hook_nic_event - data structure describing events related to network interfaces SYNOPSIS
#include <sys/neti.h> #include <sys/hook.h> #include <sys/hook_event.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). DESCRIPTION
The hook_nic_event structure contains fields that relate to an event that has occurred and belongs to a network interface. This structure is passed through to callbacks for NE_PLUMB, NE_UNPLUMB, NE_UP, NE_DOWN and NE_ADDRESS_CHANGE events. A callback may not alter any of the fields in this structure. STRUCTURE MEMBERS
net_data_t hne_family; phy_if_t pkt_private; lif_if_t hne_lif; nic_event_t hne_event; nic_event_data_t hne_data; size_t hne_datalen; The following fields are set for each event: hne_family A valid reference for the network protocol that owns this network interface and can be in calls to other netinfo(9F) func- tions. hne_nic The physical interface to which an event belongs. hne_event A value that indicates the respective event. The current list of available events is: NE_PLUMB an interface has just been created. NE_UNPLUMB an interface has just been destroyed and no more events should be received for it. NE_UP an interface has changed the state to "up" and may now generate packet events. NE_DOWN an interface has changed the state to "down" and will no longer generate packet events. NE_ADDRESS_CHANGE an address on an interface has changed. hne_lif refers to the logical interface for which the change is occurring, hne_data is a pointer to a sockaddr structure that is hne_datalen bytes long and contains the new network address. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
netinfo(9F) SunOS 5.11 1 May 2008 hook_nic_event(9S)

Check Out this Related Man Page

net_getlifaddr(9F)					   Kernel Functions for Drivers 					net_getlifaddr(9F)

NAME
net_getlifaddr - determine a network address for a given interface SYNOPSIS
#include <sys/neti.h> int net_getlifaddr(const net_data_t net, const phy_if_t ifp, const net_if_t lif, int const type, struct sockaddr* storage); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). ifp value returned from a successful call to net_phylookup(9F) or net_phygetnext(9F), indicating which network interface the infor- mation should be returned from. lif indicates the logical interface from which to fetch the address. type indicates what type of address should be returned. See below for more details on this field. storage pointer to an area of memory to store the address data. DESCRIPTION
The net_getlifaddr() function retrieves the address information for each logical interface. Each call to net_getlifaddr() requires that the caller pass a pointer to an array of address information types to retrieve, and an accompanying pointer to an array of pointers to struct sockaddr structures to which to copy the address information. See net_lifgetnext(9F) for an example on how to use this function. Each member of the address type array should be one of the values listed here. NA_ADDRESS Return the network address associated with the logical interface (lif) that belongs to the network interface (ifp). NA_PEER Return the address assigned to the remote host for point to point network interfaces for the given network/logical inter- face. NA_BROADCAST Return the broadcast address assigned to the given network/logical interface for network interfaces that support broadcast packets. NA_NETMASK Return the netmask associated with the given network/logical interface for network interfaces that support broadcast pack- ets. RETURN VALUES
The net_getlifaddr() function returns: -1 The network protocol does not support this function. 0 Successful completion. 1 Unsuccessful. CONTEXT
The net_getifaddr() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_lifgetnext(9F), net_phylookup(9F), net_phygetnext(9F)net_protocol_lookup(9F) SunOS 5.11 13 Oct 2008 net_getlifaddr(9F)
Man Page