Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

fmodsw(9s) [opensolaris man page]

fmodsw(9S)						    Data Structures for Drivers 						fmodsw(9S)

NAME
fmodsw - STREAMS module declaration structure SYNOPSIS
#include <sys/stream.h> #include <sys/conf.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) DESCRIPTION
The fmodsw structure contains information for STREAMS modules. All STREAMS modules must define a fmodsw structure. f_name must match mi_idname in the module_info structure. See module_info(9S). f_name should also match the module binary name. (See WARN- INGS.) All modules must set the f_flag to D_MP to indicate that they safely allow multiple threads of execution. See mt-streams(9F) for additional flags. STRUCTURE MEMBERS
char f_name[FMNAMESZ + 1]; /* module name */ struct streamtab *f_str; /* streams information */ int f_flag; /* flags */ SEE ALSO
mt-streams(9F), modlstrmod(9S), module_info(9S) STREAMS Programming Guide WARNINGS
If f_name does not match the module binary name, unexpected failures can occur. SunOS 5.11 14 Nov 2002 fmodsw(9S)

Check Out this Related Man Page

module_info(9S) 					    Data Structures for Drivers 					   module_info(9S)

NAME
module_info - STREAMS driver identification and limit value structure SYNOPSIS
#include <sys/stream.h> INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). DESCRIPTION
When a module or driver is declared, several identification and limit values can be set. These values are stored in the module_info struc- ture. The module_info structure is intended to be read-only. However, the flow control limits (mi_hiwat and mi_lowat) and the packet size limits (mi_minpsz and mi_maxpsz) are copied to the QUEUE structure, where they can be modified. For a driver, mi_idname must match the name of the driver binary file. For a module, mi_idname must match the fname field of the fmodsw structure. See fmodsw(9S) for details. STRUCTURE MEMBERS
ushort_t mi_idnum; /* module ID number */ char *mi_idname; /* module name */ ssize_t mi_minpsz; /* minimum packet size */ ssize_t mi_maxpsz; /* maximum packet size */ size_t mi_hiwat; /* high water mark */ size_t mi_lowat; /* low water mark */ The constant FMNAMESZ, limiting the length of a module's name, is set to eight in this release. SEE ALSO
fmodsw(9S), queue(9S) STREAMS Programming Guide SunOS 5.10 26 Nov 2002 module_info(9S)
Man Page