Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_idevice_cookie(9s) [opensolaris man page]

ddi_idevice_cookie(9S)					    Data Structures for Drivers 				    ddi_idevice_cookie(9S)

NAME
ddi_idevice_cookie - device interrupt cookie SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). This interface is obsolete. Use the new interrupt interfaces referenced in Intro(9F). Refer to Writing Device Drivers for more information. DESCRIPTION
The ddi_idevice_cookie_t structure contains interrupt priority and interrupt vector information for a device. This structure is useful for devices having programmable bus-interrupt levels. ddi_add_intr(9F) assigns values to the ddi_idevice_cookie_t structure members. STRUCTURE MEMBERS
u_short idev_vector; /* interrupt vector */ ushort_t idev_priority; /* interrupt priority */ The idev_vector field contains the interrupt vector number for vectored bus architectures such as VMEbus. The idev_priority field contains the bus interrupt priority level. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Obsolete | +-----------------------------+-----------------------------+ SEE ALSO
ddi_add_intr(9F), Intro(9F) Writing Device Drivers SunOS 5.11 19 Oct 2005 ddi_idevice_cookie(9S)

Check Out this Related Man Page

ddi_dev_nintrs(9F)					   Kernel Functions for Drivers 					ddi_dev_nintrs(9F)

NAME
ddi_dev_nintrs - return the number of interrupt specifications a device has SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dev_nintrs(dev_info_t *dip, int *resultp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). This interface is obsolete. Use the new interrupt interfaces referenced in Intro(9F). Refer to Writing Device Drivers for more information. DESCRIPTION
The ddi_dev_nintrs() function returns the number of interrupt specifications a device has in *resultp. RETURN VALUES
The ddi_dev_nintrs() function returns: DDI_SUCCESS A successful return. The number of interrupt specifications that the device has is set in resultp. DDI_FAILURE The device has no interrupt specifications. CONTEXT
The ddi_dev_nintrs() function can be called from user, interrupt, or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Obsolete | +-----------------------------+-----------------------------+ SEE ALSO
isa(4), sbus(4), ddi_add_intr(9F), ddi_dev_nregs(9F), ddi_dev_regsize(9F), Intro(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_dev_nintrs(9F)
Man Page

4 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

BUS error intr - problem

Hi, I have fundamentals of unix. I got a problem on my Realtime electronic system having IOPs as the man-machine interface. Repeatedly bus interrupt error message is coming onto the VDU. For the sake of redundacy(hot standby), two IOPs are synchronised for the electronic system data. OS... (0 Replies)
Discussion started by: pvkrishna
0 Replies

2. Filesystems, Disks and Memory

NOTICE:u79n:Abnormal interrupt! int_status=FC67C0D0

I am receiving the message of "NOTICE:u79n:Abnormal interrupt! int_status=FC67C0D0" periodically on my server. (version is 5.06) It is not creating a critical problem and my applications are running withouth any problem. What is the reason of that and how can I solve that problem? (1 Reply)
Discussion started by: fadil
1 Replies

3. Shell Programming and Scripting

Sending an interrupt in a script?

Is it possible to sent a ^C interrupt via the command line? For example if I want to tail a log for 10 minutes at a time, kill the tail and then start it again is there a way to go about that? I would imagine there would be some way to do it by finding and killing the PID, but I'm curious if... (2 Replies)
Discussion started by: DeCoTwc
2 Replies

4. Programming

Traversing member of structure of vector C++

Hello, I want to loop thru a vector composed of many entries as structure, which contains sequenceID and sequence. At looping, delete any structure if the sequence is a perfect-match substring of another sequence of any other structure, so that the resulted vector contains only unique sequences.... (1 Reply)
Discussion started by: yifangt
1 Replies