Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

usb_get_addr(9f) [opensolaris man page]

usb_get_addr(9F)					   Kernel Functions for Drivers 					  usb_get_addr(9F)

NAME
usb_get_addr - Retrieve device USB address SYNOPSIS
#include <sys/usb/usba.h> int usb_get_addr(dev_info_t *dip); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
dip Pointer to the device's dev_info structure. DESCRIPTION
The usb_get_addr() function returns the current USB bus address for debugging purposes. The returned address is unique for a specific USB bus, and may be replicated if multiple host controller instances are present on the system. RETURN VALUES
On success: USB device address. On failure: returns 0. Fails if dip is NULL. CONTEXT
May be called from user, kernel or interrupt context. EXAMPLES
int usb_addr; usb_addr = usb_get_addr(dip); ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Committed | +-----------------------------+-----------------------------+ |Availability |SUNWusb | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), usb_pipe_open(9F) SunOS 5.11 Feb 9 2004 usb_get_addr(9F)

Check Out this Related Man Page

usb_handle_remote_wakeup(9F)				   Kernel Functions for Drivers 			      usb_handle_remote_wakeup(9F)

NAME
usb_handle_remote_wakeup - Enable or disable remote wakeup on USB devices SYNOPSIS
#include <sys/usb/usba.h> int usb_handle_remote_wakeup(dev_info_t *dip, int cmd); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
dip Pointer to the device's dev_info structure. cmd Command. Either USB_REMOTE_WAKEUP_ENABLE or USB_REMOTE_WAKEUP_DISABLE. DESCRIPTION
The usb_handle_remote_wakeup() function enables or disables remote wakeup on a USB device. This call can block. RETURN VALUES
USB_SUCCESS Remote wakeup is successfully enabled or disabled. USB_FAILURE Remote wakeup is not supported by the device. An internal error occurred. CONTEXT
May be called from user or kernel context. EXAMPLES
uint_t *pwrstates; /* Hook into device's power management. Enable remote wakeup. */ if (usb_create_pm_components(dip, pwrstates) == USB_SUCCESS) { usb_handle_remote_wakeup(dip, USB_REMOTE_WAKEUP_ENABLE); } ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |PCI-based systems | +-----------------------------+-----------------------------+ |Interface stability |Committed | +-----------------------------+-----------------------------+ |Availability |SUNWusb | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), pm_busy_component(9F), pm_idle_component(9F), pm_lower_power(9F), pm_raise_power(9F), usb_clr_feature(9F), usb_cre- ate_pm_components(9F), usb_get_cfg(9F), usb_get_dev_data(9F), usb_register_hotplug_cbs(9F), usb_cfg_descr(9S) SunOS 5.11 5 Feb 2004 usb_handle_remote_wakeup(9F)
Man Page