Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

scsi_get_device_type_scsi_options(9f) [opensolaris man page]

scsi_get_device_type_scsi_options(9F)			   Kernel Functions for Drivers 		     scsi_get_device_type_scsi_options(9F)

NAME
scsi_get_device_type_scsi_options - look up per-device-type scsi-options property SYNOPSIS
#include <sys/scsi/scsi.h> int scsi_get_device_type_scsi_options(dev_info_t *dip, struct scsi_device *devp, int default_scsi_options); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
dip Pointer to the device info node for this HBA driver. devp Pointer to a scsi_device(9S) structure of the target. default_scsi_options Value returned if no match is found. DESCRIPTION
The scsi_get_device_type_scsi_options() function looks up the property device-type-scsi-options-list, which can be specified in the HBA's driver.conf(4) file. This property allows specification of scsi-options on a per-device-type basis. The formal syntax is: device-type-scsi-options-list = <duplet> [, <duplet> *]; where: <duplet> := <vid+pid>, <scsi-options-property-name> and: <scsi-options-property-name> = <value>; The string <vid+pid> is returned by the device on a SCSI inquiry command. This string can contain any character in the range 0x20-0x7e. Characters such as double quote (") or single quote ('), which are not permitted in property value strings, are represented by their octal equivalent (for example, 42 and 47). Trailing spaces can be truncated. For example: device-type-scsi-options-list= "SEAGATE ST32550W", "seagate-options", "EXABYTE EXB-2501". "exabyte-options", "IBM OEM DFHSS4S", "ibm-options"; seagate-options = 0x78; exabyte-options = 0x58; ibm-options = 0x378; The scsi_get_device_type_scsi_options() function searches the list of duplets for a matching INQUIRY string. If a match is found, scsi_get_device_type_scsi_options() returns the corresponding value. RETURN VALUES
scsi_get_device_type_scsi_options() returns the scsi-options value found, or if no match is found the default_scsi_options value passed in. CONTEXT
This function can be called from kernel or interrupt context. SEE ALSO
Writing Device Drivers SunOS 5.11 19 Nov 2001 scsi_get_device_type_scsi_options(9F)

Check Out this Related Man Page

tran_tgt_init(9E)						Driver Entry Points						 tran_tgt_init(9E)

NAME
tran_tgt_init - request to initialize HBA resources on behalf of a particular target SYNOPSIS
#include <sys/scsi/scsi.h> void prefixtran_tgt_init(dev_info_t *hba_dip, dev_info_t *tgt_dip, scsi_hba_tran_t *hba_tran, struct scsi_device *sd); INTERFACE LEVEL
Solaris architecture specific (Solaris DDI). PARAMETERS
hba_dip Pointer to a dev_info_t structure, referring to the HBA device instance. tgt_dip Pointer to a dev_info_t structure, referring to the target device instance. hba_tran Pointer to a scsi_hba_tran(9S) structure, consisting of the HBA's transport vectors. sd Pointer to a scsi_device(9S) structure, describing the target. DESCRIPTION
The tran_tgt_init() vector in the scsi_hba_tran(9S) structure may be initialized during the HBA driver's attach(9E) to point to an HBA driver function to be called by the system when an instance of a target device is being created. The tran_tgt_init() vector, if not NULL,is called after the dev_info node structure is created for this target device instance, but before probe(9E) for this instance is called. Before receiving transport requests from the target driver instance, the HBA may perform any initialization required for this par- ticular target during the call of the tran_tgt_init() vector. Note that hba_tran will point to a cloned copy of the scsi_hba_tran_t structure allocated by the HBA driver if the SCSI_HBA_TRAN_CLONE flag was specified in the call to scsi_hba_attach(9F). In this case, the HBA driver may choose to initialize the tran_tgt_private field in the structure pointed to by hba_tran, to point to the data specific to the particular target device instance. RETURN VALUES
tran_tgt_init() must return: DDI_SUCCESS the HBA driver can support the addressed target, and was able to initialize per-target resources. DDI_FAILURE the HBA driver cannot support the addressed target, or was unable to initialize per-target resources. In this event, the initialization of this instance of the target device will not be continued, the target driver's probe(9E) will not be called, and the tgt_dip structure destroyed. SEE ALSO
attach(9E), probe(9E), tran_tgt_free(9E), tran_tgt_probe(9E), scsi_hba_attach_setup(9F), scsi_device(9S), scsi_hba_tran(9S) Writing Device Drivers SunOS 5.10 1 Nov 1993 tran_tgt_init(9E)
Man Page