putnext(9F) Kernel Functions for Drivers putnext(9F)NAME
putnext - send a message to the next queue
SYNOPSIS
#include <sys/stream.h>
#include <sys/ddi.h>
void putnext(queue_t *q, mblk_t *mp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Pointer to the queue from which the message mp will be sent.
mp Message to be passed.
DESCRIPTION
The putnext() function is used to pass a message to the put(9E) routine of the next queue in the stream.
RETURN VALUES
None.
CONTEXT
The putnext() function can be called from user, interrupt, or kernel context.
EXAMPLES
See allocb(9F) for an example of using putnext().
SEE ALSO put(9E), allocb(9F), put(9F), qprocson(9F)
Writing Device Drivers
STREAMS Programming Guide
NOTES
The put() and putnext() functions should be called only after qprocson() is finished.
SunOS 5.11 16 Jan 2006 putnext(9F)
Check Out this Related Man Page
putnext(9F) Kernel Functions for Drivers putnext(9F)NAME
putnext - send a message to the next queue
SYNOPSIS
#include <sys/stream.h>
#include <sys/ddi.h>
void putnext(queue_t *q, mblk_t *mp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
q Pointer to the queue from which the message mp will be sent.
mp Message to be passed.
DESCRIPTION
putnext() is used to pass a message to the put(9E) routine of the next queue in the stream.
RETURN VALUES
None.
CONTEXT
putnext() can be called from user or interrupt context.
EXAMPLES
See allocb(9F) for an example of using putnext().
SEE ALSO put(9E), allocb(9F), put(9F), qprocson(9F)
Writing Device Drivers
STREAMS Programming Guide
NOTES
The put() and putnext() functions should be called only after qprocson() is finished.
SunOS 5.10 18 Feb 1998 putnext(9F)
hi experts,
i'm having more error log on /var/adm/messages could anyone help to description what is this error logs means???? and how to fix it? below is the logs :
Nov 22 20:03:40 USSDGtbs-1 unix:
Nov 22 20:03:40 USSDGtbs-1 ^Mpanic/thread=3001345edc0:
Nov 22 20:03:40 USSDGtbs-1 unix: ... (2 Replies)
Dear Friends,
Sun Fire E2900 crashed. I collected explorer output. core dump files been generated.
There some interesting output files related to crash dumps, that I need some help from you guys to understand.
The file in the explorer output is under /sysconfig/crash it's called:... (5 Replies)
My sparc solaris 8 server crashed/rebooted yesterday and I have the vmcore files. I have some initial output from SCAT and ACT. I have not included all but any info would be helpful. I can supply more output if necessary.
Thanks you.
Can I have any information about this ACT and SCAT... (2 Replies)
Hi all,
I have a AIX kernel STREAMS question need your help,
I need to implement a firewall on AIX and get packet raw data then decide pass or drop it,
I've seen similiar firewall code on HP-UX,
on HP-UX, you have to implement a "dlpi STREAMS driver", and specify it as a "dlpi" driver in... (1 Reply)