proc_signal(9F) Kernel Functions for Drivers proc_signal(9F)NAME
proc_signal, proc_ref, proc_unref - send a signal to a process
int proc_signal(void *pref, int sig);
Solaris DDI specific (Solaris DDI).
pref A handle for the process to be signalled.
sig Signal number to be sent to the process.
This set of routines allows a driver to send a signal to a process. The routine proc_ref() is used to retrieve an unambiguous reference to
the process for signalling purposes. The return value can be used as a unique handle on the process, even if the process dies. Because sys-
tem resources are committed to a process reference, proc_unref() should be used to remove it as soon as it is no longer needed.proc_sig-
nal() is used to send signal sig to the referenced process. The following set of signals may be sent to a process from a driver:
SIGHUP The device has been disconnected.
SIGINT The interrupt character has been received.
SIGQUIT The quit character has been received.
SIGPOLL A pollable event has occurred.
SIGKILL Kill the process (cannot be caught or ignored).
SIGWINCH Window size change.
SIGURG Urgent data are available.
See signal.h(3HEAD) for more details on the meaning of these signals.
If the process has exited at the time the signal was sent, proc_signal() returns an error code; the caller should remove the reference on
the process by calling proc_unref().
The driver writer must ensure that for each call made to proc_ref(), there is exactly one corresponding call to proc_unref().
The proc_ref() returns the following:
pref An opaque handle used to refer to the current process.
The proc_signal() returns the following:
0 The process existed before the signal was sent.
-1 The process no longer exists; no signal was sent.
The proc_unref() and proc_signal() functions can be called from user, interrupt, or kernel context. The proc_ref() function should be
called only from user context.
SEE ALSO signal.h(3HEAD), putnextctl1(9F)
Writing Device Drivers
SunOS 5.11 16 Jan 2006 proc_signal(9F)
Check Out this Related Man Page
KILL(2) Linux Programmer's Manual KILL(2)NAME
kill - send signal to a process
int kill(pid_t pid, int sig);
The kill system call can be used to send any signal to any process group or process.
If pid is positive, then signal sig is sent to pid.
If pid equals 0, then sig is sent to every process in the process group of the current process.
If pid equals -1, then sig is sent to every process except for process 1 (init), but see below.
If pid is less than -1, then sig is sent to every process in the process group -pid.
If sig is 0, then no signal is sent, but error checking is still performed.
On success, zero is returned. On error, -1 is returned, and errno is set appropriately.
EINVAL An invalid signal was specified.
ESRCH The pid or process group does not exist. Note that an existing process might be a zombie, a process which already committed termi-
nation, but has not yet been wait()ed for.
EPERM The process does not have permission to send the signal to any of the receiving processes. For a process to have permission to send
a signal to process pid it must either have root privileges, or the real or effective user ID of the sending process must equal the
real or saved set-user-ID of the receiving process. In the case of SIGCONT it suffices when the sending and receiving processes
belong to the same session.
It is impossible to send a signal to task number one, the init process, for which it has not installed a signal handler. This is done to
assure the system is not brought down accidentally.
POSIX 1003.1-2001 requires that kill(-1,sig) send sig to all processes that the current process may send signals to, except possibly for
some implementation-defined system processes. Linux allows a process to signal itself, but on Linux the call kill(-1,sig) does not signal
the current process.
Across different kernel versions, Linux has enforced different rules for the permissions required for an unprivileged process to send a
signal to another process. In kernels 1.0 to 1.2.2, a signal could be sent if the effective user ID of the sender matched that of the
receiver, or the real user ID of the sender matched that of the receiver. From kernel 1.2.3 until 1.3.77, a signal could be sent if the
effective user ID of the sender matched either the real or effective user ID of the receiver. The current rules, which conform to POSIX
1003.1-2001, were adopted in kernel 1.3.78.
SVr4, SVID, POSIX.1, X/OPEN, BSD 4.3, POSIX 1003.1-2001
SEE ALSO _exit(2), exit(3), signal(2), signal(7)Linux 2.5.0 2001-12-18 KILL(2)