Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

net_protocol_walk(9f) [opensolaris man page]

net_protocol_walk(9F)					   Kernel Functions for Drivers 				     net_protocol_walk(9F)

NAME
net_protocol_walk - step through the list of registered network protocols SYNOPSIS
#include <sys/neti.h> net_data_t *net_protocol_walk(net_data_t net); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). DESCRIPTION
The net_protocol_walk() function walks through all of the network protocols that have been registered with this interface. The initial call to net_protocol_walk() should be made by passing in NULL as the value for net. When this function returns NULL, the end of the list has been reached. A caller of net_protocol_walk() is required to walk through the entire list of network protocols, until NULL is returned or, when finished with using the value returned, pass it into a call to net_protocol_release(9F). RETURN VALUES
The net_protocol_walk() function returns NULL when the end of the list is returned. Otherwise, it returns a non-NULL value as a token for being passed into other function calls within this interface. CONTEXT
The net_protocol_walk() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_protocol_lookup(9F), net_protocol_release(9F), attributes(5) SunOS 5.11 1 May 2008 net_protocol_walk(9F)

Check Out this Related Man Page

net_getifname(9F)					   Kernel Functions for Drivers 					 net_getifname(9F)

NAME
net_getifname - determine the name given to a network interface SYNOPSIS
#include <sys/neti.h> int net_getifname(const net_data_t net, const phy_if_t ifp, char *buffer, size_t buflen); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). ifp value returned from a successful call to net_phylookup(9F) or net_phygetnext(9F). buffer pointer to the buffer in which to write the interface name. buflen size of the buffer in which to store the interface name. DESCRIPTION
The net_getifname() function copies the name of the network interface into the buffer provided. The name will always be null-terminated. If the buffer is too small to fit both the interface name and the null-terminated name, the name in the buffer is truncated to fit. See net_phygetnext(9F) for an example on how to use this function. RETURN VALUES
The net_getifname() function returns: -1 The network protocol does not support this function. 0 Successful completion. 1 Unsuccessful. CONTEXT
The net_getifname() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F) SunOS 5.11 1 May 2008 net_getifname(9F)
Man Page