Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

net_lifgetnext(9f) [opensolaris man page]

net_lifgetnext(9F)					   Kernel Functions for Drivers 					net_lifgetnext(9F)

NAME
net_lifgetnext - search through a list of logical network interfaces SYNOPSIS
#include <sys/neti.h> net_if_t net_lifgetnext(const net_data_t net, const phy_if_t ifp, net_if_t lif); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). ifp value returned from a successful call to net_phylookup(9F) or net_phygetnext(9F). lif value returned from a successful call to this function. DESCRIPTION
The net_lifgetnext() function is used to search through all of the logical interfaces that are associated with a physical network inter- face. To start searching through this list, a value of 0 should be passed through as the value of lif. When 0 is returned by this function, the last of the interfaces owned by this protocol has been reached. When called successfully, the value returned represents a logical interface that exists, at the time of the call, within the scope of the network interface and its assigned network protocol. This value is only guaranteed to be unique for a name within the scope of the network interface and its assigned protocol. EXAMPLES
net_data_t net; phy_if_t ifp; net_if_t lif; char buffer[32]; net_ifaddr_t atype[1]; struct sockaddr_in sin[1]; net = net_protocol_lookup("inet"); if (net != NULL) { atype[0] = NA_ADDRESS; ifp = net_phylookup(net, "hme0"); for (lif = net_lifgetnext(net, 0); lif != 0; lif = net_lifgetnext(net, lif)) { /* Do something with lif */ if (net_getlifaddr(net, ifp, lif, 1, atype, sin) == 0) printf("hme0:%d %x0, lif, ntohl(sin[0].sin_addr.s_addr)); } } RETURN VALUES
The net_lifgetnext() function returns a value of -1 if it is not supported by the network protocol and a value of 0 if an attempt to go beyond the last network interface is made. Otherwise, it returns a value representing a network interface. CONTEXT
The net_lifgetnext() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_phygetnext(9F), net_phylookup(9F) SunOS 5.11 1 May 2008 net_lifgetnext(9F)

Check Out this Related Man Page

net_routeto(9F) 					   Kernel Functions for Drivers 					   net_routeto(9F)

NAME
net_routeto - indicate which network interface packets are sent SYNOPSIS
#include <sys/neti.h> phy_if_t net_routeto(const net_data_t *net, struct sockaddr *address, struct sockaddr *nexthop); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_lookup(9F). address network address to find a path out of the machine for. nexthop pointer to the sockaddr structure in which to store the address of the next hop. If this information is not required, the value NULL may be passed instead. DESCRIPTION
The net_routeto() function indicates which network interface packets destined for a particular address would be sent out of, according to the systems network routing tables. If next is supplied as a non-NULL pointer, the IP address of the nexthop router to be used is returned in it. RETURN VALUES
The net_routeto() function returns: -1 The network protocol does not support this function. 0 This function cannot find a route for the address given. >0 Indicates which network interface can be used to reach the given address. CONTEXT
The net_routeto() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F), attributes(5) SunOS 5.11 1 May 2008 net_routeto(9F)
Man Page