Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

net_instance_unregister(9f) [opensolaris man page]

net_instance_unregister(9F)				   Kernel Functions for Drivers 			       net_instance_unregister(9F)

NAME
net_instance_unregister - disable a set of instances SYNOPSIS
#include <sys/neti.h> void net_instance_unregister(net_instance_t *instances); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
instances must be a pointer returned by net_instance_alloc(9F). DESCRIPTION
The net_instance_unregister() function removes the set of instances that were previously registered with the net_instance_register() func- tion. RETURN VALUES
If the net_instance_unregister() function succeeds, 0 is returned. Otherwise, an error indicating the problem encountered. CONTEXT
The net_instance_unregister() function may be called from user, kernel, or interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_instance_alloc(9F), net_instance_register(9F), attributes(5), net_instance_t(9S) SunOS 5.11 1 May 2008 net_instance_unregister(9F)

Check Out this Related Man Page

net_instance_alloc(9F)					   Kernel Functions for Drivers 				    net_instance_alloc(9F)

NAME
net_instance_alloc - allocate a net_instance_t structure SYNOPSIS
#include <sys/neti.h> net_instance_t *net_instance_alloc(const int version); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
version must always be the symbol NETI_VERSION. DESCRIPTION
The net_instance_alloc() function allocates a net_instance_t structure, returning a pointer for the caller to use. RETURN VALUES
Upon success, net_instance_alloc() returns a pointer to the allocated net_instance_t structure. On failure, it returns a NULL pointer. CONTEXT
The net_instance_alloc() function may be called from user or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_instance_free(9F), attributes(5), net_inject_t(9S) SunOS 5.11 1 May 2008 net_instance_alloc(9F)
Man Page