Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

net_hook_register(9f) [opensolaris man page]

net_hook_register(9F)					   Kernel Functions for Drivers 				     net_hook_register(9F)

NAME
net_hook_register - add a hook to be called in event processing SYNOPSIS
#include <sys/neti.h> net_hook_t net_hook_register(const net_data_t net, hook_t *hook); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_register(). hook pointer to a hook_t structure. DESCRIPTION
The net_hook_register() function uses hooks that allow callbacks to be registered with events that belong to a network protocol. A success- ful call to net_hook_register() requires that a valid handle for a network protocol be provided (the net parameter), along with a hook description that includes a reference to an available event. While it is possible to use the same hook_t structure with multiple calls to net_hook_register(), it is not encouraged. The hook_t structure passed in with this function is described by hook_t(9S). The following describes how this structure is used. h_func Must be non-NULL and represent a function that fits the specified interface. h_name Gives the hook a name that represents its owner. No duplication of h_name among the hooks present for an event is allowed. h_flags Currently unused and must be set to 0. h_hint, h_hintvalue Specify a hint to net_hook_register() on how to insert this hook. If the hint cannot be specified, then an error is returned. h_arg; May take any value that the consumer wishes to have passed back when the hook is activated. RETURN VALUES
If the net_hook_register() function succeeds, 0 is returned. Otherwise, one of the following errors is returned: ENOMEM The system cannot allocate any more memory to support registering this hook. ENXIO A hook cannot be found among the given family of events. EEXIST A hook with the given h_name already exists on that event. ESRCH A before or after dependency cannot be satisfied due to the hook with EBUSY The h_hint field specifies a hint that cannot currently be satisfied because it conflicts with another hook. An example of this might be specifying HH_FIRST or HH_LAST when another hook has already been registered with this value. CONTEXT
The net_hook_register() function may be called from user or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_hook_unregister(9F), hook_t(9S) SunOS 5.11 1 May 2008 net_hook_register(9F)

Check Out this Related Man Page

hook_t(9S)						    Data Structures for Drivers 						hook_t(9S)

NAME
hook_t - callback structure for subscribing to netinfo events SYNOPSIS
#include <sys/hook.h> INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). DESCRIPTION
The hook_t data structure defines a callback that is to be inserted into a networking event. This data structure must be allocated with a call to hook_alloc() and released with a call to hook_free(). STRUCTURE MEMBERS
hook_func_t h_func; /* callback function to invoke */ char *h_name; /* unique name given to the hook */ int h_flags; hook_hint_t h_hint; /* insertion hint type */ uintptr_t h_hintvalue; /* used with h_hint */ void *h_arg; /* value to pass into h_func */ typedef int (*hook_func_t)(net_event_t token, hook_data_t info, void *); HINT TYPES Hook hints are hints that are used at the time of insertion and are not rules that enforce where a hook lives for its entire lifetime on an event. The valid values for the h_hint field are: HH_NONE Insert the hook wherever convenient. HH_FIRST Place the hook first on the list of hooks. HH_LAST Place the hook last on the list of hooks. HH_BEFORE Place the hook before another hook on the list of hooks. The value in h_hintvalue must be a pointer to the name of another hook. HH_AFTER Place the hook after another hook on the list of hooks. The value in h_hintvalue must be a pointer to the name of another hook. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
netinfo(9F) SunOS 5.11 1 May 2008 hook_t(9S)
Man Page