Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

net_event_notify_register(9f) [opensolaris man page]

net_event_notify_register(9F)				   Kernel Functions for Drivers 			     net_event_notify_register(9F)

NAME
net_event_notify_register, net_event_notify_unregister - add/delete a function to be called for changes to a event SYNOPSIS
#include <sys/hook.h> #include <sys/neti.h> int net_event_notify_register(net_handle_t family, char *event, hook_notify_fn_t *callback, void *arg); int net_event_notify_unregister(net_handle_t family, char *event, hook_notify_fn_t *callback); typedef int (* hook_notify_fn_t)(hook_notify_cmd_t command, void *arg, const char *name1, const char *name2, const char *name3); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
family value returned from a successful call to net_protocol_lookup(). callback function to call when a change occurs. event name of the event for which notification of change is desired. arg pointer to pass into the callback() function when a change occurs. DESCRIPTION
The net_event_notify_register() function registers a function represented by the pointer callback to be called when there is a change to the event represented by family. The types of changes for which notifications are available for is currently limited to the addition and removal of hooks. The net_event_notify_unregister() function indicates that there is no longer any desire to receive notification of changes to the event through function calls to the specified callback. The name of a hook should be considered a private interface unless otherwise specified. The hook names used by IPFilter in Solaris are a public, but uncommitted, interface. Multiple callback functions may be registered through this interface. The same set of parameters is passed to each callback function. The memory referenced through the pointers passed to the callback should be treated as pointing to read-only memory. Changing this data is strictly prohibited. The function that is called when the event occurs must not block any other events. The arguments passed through to the callback are as follows (the command is either HN_REGISTER or HN_UNREGISTER): name1 is the name of the protocol. name2 is the name of the event name3 is the name of the hook being added/removed RETURN VALUES
If these functions succeed, 0 is returned. Otherwise, the following error is returned: EEXIST the given callback function is already registered. CONTEXT
These functions may be called from user or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), net_hook_register(9F), net_hook_unregister(9F), net_protocol_lookup(9F) SunOS 5.11 30 Oct 2008 net_event_notify_register(9F)

Check Out this Related Man Page

net_hook_register(9F)					   Kernel Functions for Drivers 				     net_hook_register(9F)

NAME
net_hook_register - add a hook to be called in event processing SYNOPSIS
#include <sys/neti.h> net_hook_t net_hook_register(const net_data_t net, hook_t *hook); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
net value returned from a successful call to net_protocol_register(). hook pointer to a hook_t structure. DESCRIPTION
The net_hook_register() function uses hooks that allow callbacks to be registered with events that belong to a network protocol. A success- ful call to net_hook_register() requires that a valid handle for a network protocol be provided (the net parameter), along with a hook description that includes a reference to an available event. While it is possible to use the same hook_t structure with multiple calls to net_hook_register(), it is not encouraged. The hook_t structure passed in with this function is described by hook_t(9S). The following describes how this structure is used. h_func Must be non-NULL and represent a function that fits the specified interface. h_name Gives the hook a name that represents its owner. No duplication of h_name among the hooks present for an event is allowed. h_flags Currently unused and must be set to 0. h_hint, h_hintvalue Specify a hint to net_hook_register() on how to insert this hook. If the hint cannot be specified, then an error is returned. h_arg; May take any value that the consumer wishes to have passed back when the hook is activated. RETURN VALUES
If the net_hook_register() function succeeds, 0 is returned. Otherwise, one of the following errors is returned: ENOMEM The system cannot allocate any more memory to support registering this hook. ENXIO A hook cannot be found among the given family of events. EEXIST A hook with the given h_name already exists on that event. ESRCH A before or after dependency cannot be satisfied due to the hook with EBUSY The h_hint field specifies a hint that cannot currently be satisfied because it conflicts with another hook. An example of this might be specifying HH_FIRST or HH_LAST when another hook has already been registered with this value. CONTEXT
The net_hook_register() function may be called from user or kernel context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Availability |SUNWcsu | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
net_hook_unregister(9F), hook_t(9S) SunOS 5.11 1 May 2008 net_hook_register(9F)
Man Page