Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ldi_strategy(9f) [opensolaris man page]

ldi_strategy(9F)					   Kernel Functions for Drivers 					  ldi_strategy(9F)

NAME
ldi_strategy - Device strategy request SYNOPSIS
#include <sys/sunldi.h> int ldi_strategy(ldi_handle_t lh, struct buf *bp); PARAMETERS
lh Layered handle. bp Pointer to the buf(9S) structure. DESCRIPTION
The ldi_strategy() function passes a strategy request to the device entry point for the device specified by the layered handle. This opera- tion is supported for block devices. RETURN VALUES
The ldi_strategy() function returns 0 if the strategy request has been passed on to the target device. Other possible return values are: EINVAL Invalid input parameters. ENOTSUP Operation is not supported for this device. Once the request has been passed on to the target devices strategy entry point, any further errors will be reported by bioerror(9F) and biodone(9F). See the strategy(9E) entry point for more information. CONTEXT
This function may be called from user or kernel context. SunOS 5.11 3 June 2003 ldi_strategy(9F)

Check Out this Related Man Page

ldi_aread(9F)						   Kernel Functions for Drivers 					     ldi_aread(9F)

NAME
ldi_aread, ldi_awrite - Issue an asynchronous read or write request to a device SYNOPSIS
#include <sys/sunldi.h> int ldi_aread(ldi_handle_t lh, struct aio_req *aio_reqp, cred_t *cr); int ldi_awrite(ldi_handle_t lh, struct aio_req *aio_reqp, cred_t *cr); PARAMETERS
lh Layered handle. cr Pointer to a credential structure. aio_reqp Pointer to the aio_req(9S) structure that describes where the data is to be stored or obtained from. DESCRIPTION
The ldi_awrite() function passes an asynchronous write request to a device entry point specified by the layered handle. This operation is supported for block and character devices. The ldi_aread() function passes an asynchronous read request to a device entry point specified by the layered handle. This operation is supported for block and character devices. RETURN VALUES
The ldi_awrite() and ldi_aread() functions return 0 upon success. If a failure occurs before the request is passed on to the device, the possible return values are shown below. Otherwise any other error number may be returned by the device. EINVAL Invalid input parameters. ENOTSUP Operation is not supported for this device. CONTEXT
These functions may be called from user context. SunOS 5.10 3 June 2003 ldi_aread(9F)
Man Page

2 More Discussions You Might Find Interesting

1. UNIX for Advanced & Expert Users

Kernel Programming: Finding the number of I/O requests

Hi I'd like to know a logic or a strategy to count the number of I/O requests that are being made. I have the PID of the process for which this needed to be done. Does anyone have any clue as to how to do this? This is to be done in Kernel programming in C. P.S: This is to be done in... (2 Replies)
Discussion started by: Ir1s
2 Replies

2. Shell Programming and Scripting

Issue Filtering Tail

Hi Folks, I have a log that contains data as shown below: 11:59:43,144 (1,850) Signal : .... 11:59:44,109 (1850) Bps : ..... I wish to remove "" from all lines and it is on the start of every line. I have achieved that successfully using the command: tail -f imp.log | sed 's/\... (4 Replies)
Discussion started by: umairrahman
4 Replies