Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ldi_add_event_handler(9f) [opensolaris man page]

ldi_add_event_handler(9F)				   Kernel Functions for Drivers 				 ldi_add_event_handler(9F)

NAME
ldi_add_event_handler - add NDI event service callback handler SYNOPSIS
#include <sys/ddi_obsolete.h> int ldi_add_event_handler(ldi_handle_t lh, ddi_eventcookie_t ec, void (*handler)(ldi_handle_t, ddi_eventcookie_t, void *, void *) void *arg, ldi_callback_id_t *id); INTERFACE LEVEL
Obsolete PARAMETERS
ldi_handle_t lh Layered handle representing event notification device. ddi_eventcookie_t ec Cookie returned from call to ldi_get_eventcookie(9F). void (*handler)(ldi_handle_t, ddi_eventcookie_t, void *, void *) Callback handler for NDI event service notification. void *arg Pointer to opaque data supplied by caller. Typically, this is a pointer to the layered driver's softstate structure. ldi_callback_id_t *id Pointer to registration id, where a unique registration id is returned. Registration id must be saved and used when calling ldi_remove_event_handler(9F) to unregister a callback handler. DESCRIPTION
This function is obsolete and is only maintained for compatibility. Use of this function is strongly discouraged. For equivalent function- ality provided by new interfaces, see ldi_ev_get_cookie(9F) and ldi_ev_register_callbacks(9F). The ldi_add_event_handler() function adds a callback handler to be invoked at the occurance of the event specified by the cookie. Adding a callback handler is also known as subscribing to an event. Upon successful subscription, the handler is invoked when the event occurs. You can unregister the handler by using ldi_remove_event_handler(9F). An instance of a layered driver can register multiple handlers for an event or a single handler for multiple events. Callback order is not defined and should be assumed to be random. The routine handler is invoked with the following arguments: ldi_handle_t lh Layered handle representing the device for which the event notification is requested. ddi_eventcookie_t ec Structure describing event that occurred. void *arg Opaque data pointer provided by the driver during callback registration. void *impl_data Pointer to event specific data defined by the framework that invokes the callback function. RETURN VALUES
DDI_SUCCESS Callback handler registered successfully. DDI_FAILURE Failed to register callback handler. Possible reasons include lack of resources or a bad cookie. CONTEXT
The ldi_add_event_handler() function can be called from user and kernel contexts only. SEE ALSO
ldi_ev_get_cookie(9F), ldi_ev_register_callbacks(9F), ldi_get_eventcookie(9F), ldi_remove_event_handler(9F) Writing Device Drivers NOTES
Layered drivers must remove all registered callback handlers for a device instance, represented by the layered handle, by calling ldi_remove_event_handler(9F) before the layered driver's detach(9E) routine completes. SunOS 5.11 21 Aug 2007 ldi_add_event_handler(9F)

Check Out this Related Man Page

ddi_add_event_handler(9F)				   Kernel Functions for Drivers 				 ddi_add_event_handler(9F)

NAME
ddi_add_event_handler - add an NDI event service callback handler SYNOPSIS
#include <sys/dditypes.h> #include <sys/sunddi.h> int ddi_add_event_handler(dev_info_t *dip, ddi_eventcookie_t cookie, void (*handler)(dev_info_t *, ddi_eventcookie_t, void *, void *), void *arg, ddi_registration_id_t *id); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
dev_info_t *dip Device node registering the callback. ddi_eventcookie_t cookie Cookie returned from call to ddi_get_eventcookie(9F). void (*handler)(dev_info_t *, ddi_eventcookie_t, void *, void *) Callback handler responsible for handling an NDI event service notification. void *arg Pointer to opaque data supplied by the caller. Typically, this would be a pointer to the driver's softstate structure. ddi_registration_id_t *id Pointer to registration ID where a unique registration id will be returned. Registration ID must be saved and used when calling ddi_remove_event_handler(9F) to unregister a callback. DESCRIPTION
The ddi_add_event_handler() function adds a callback handler to be invoked in the face of the event specifed by cookie. The process of adding a callback handler is also known as subscribing to an event. Upon successful subscription, the handler will be invoked by the system when the event occurs. The handler can be unregistered by using ddi_remove_event_handler(9F). An instance of a driver can register multiple handlers for an event or a single handler for multiple events. Callback order is not defined and should assumed to be random. The routine handler will be invoked with the following arguments: dev_info_t *dip Device node requesting the notification. ddi_eventcookie_t cookie Structure describing event that occurred. void *arg Opaque data pointer provided, by the driver, during callback registration. void *impl_data Pointer to event specific data defined by the framework which invokes the callback function. RETURN VALUES
DDI_SUCCESS Callback handler registered successfully. DDI_FAILURE Failed to register callback handler. Possible reasons include lack of resources or a bad cookie. CONTEXT
The ddi_add_event_handler() and handler() function can be called from user and kernel contexts only. ATTRIBUTES
See attributes(5) for a description of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Stability Level |Committed | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), ddi_get_eventcookie(9F), ddi_remove_event_handler(9F) Writing Device Drivers NOTES
Drivers must remove all registered callback handlers for a device instance by calling ddi_remove_event_handler(9F) before detach completes. SunOS 5.11 62 Nov 2003 ddi_add_event_handler(9F)
Man Page