Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

drv_usectohz(9f) [opensolaris man page]

drv_usectohz(9F)					   Kernel Functions for Drivers 					  drv_usectohz(9F)

NAME
drv_usectohz - convert microseconds to clock ticks SYNOPSIS
#include <sys/types.h> #include <sys/ddi.h> clock_t drv_usectohz(clock_t microsecs); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
microsecs The number of microseconds to convert. DESCRIPTION
The drv_usectohz() function converts a length of time expressed in microseconds to a number of system clock ticks. The time arguments to timeout(9F) and delay(9F) are expressed in clock ticks. The drv_usectohz() function is a portable interface for drivers to make calls to timeout(9F) and delay(9F) and remain binary compatible should the driver object file be used on a system with a different clock speed (a different number of ticks in a second). RETURN VALUES
The value returned is the number of system clock ticks equivalent to the microsecs argument. No error value is returned. If the clock tick equivalent to microsecs is too large to be represented as a clock_t, then the maximum clock_t value will be returned. CONTEXT
The drv_usectohz() function can be called from user, interrupt, or kernel context. SEE ALSO
delay(9F), drv_hztousec(9F), timeout(9F) Writing Device Drivers NOTES
If the microsecs argument to drv_usectohz() is less than drv_hztousec(9F), drv_usectohz() returns one tick. This, coupled with multiplica- tion, can result in significantly longer durations than expected. For example, on a machine where hz is 100, calling drv_usectohz() with a microsecs value less than 10000 returns a result equivalent to 10000 (1 tick). This type of mistake causes code such as"5000 * drv_usec- tohz(1000)" to compute a duration of 50 seconds instead of the intended 5 seconds. SunOS 5.11 24 Apr 2008 drv_usectohz(9F)

Check Out this Related Man Page

delay(9F)						   Kernel Functions for Drivers 						 delay(9F)

NAME
delay - delay execution for a specified number of clock ticks SYNOPSIS
#include <sys/ddi.h> void delay(clock_t ticks); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
ticks The number of clock cycles to delay. DESCRIPTION
delay() provides a mechanism for a driver to delay its execution for a given period of time. Since the speed of the clock varies among sys- tems, drivers should base their time values on microseconds and use drv_usectohz(9F) to convert microseconds into clock ticks. delay() uses timeout(9F) to schedule an internal function to be called after the specified amount of time has elapsed. delay() then waits until the function is called. Because timeout() is subject to priority inversion, drivers waiting on behalf of processes with real-time constraints should use cv_timedwait(9F) rather than delay(). delay() does not busy-wait. If busy-waiting is required, use drv_usecwait(9F). CONTEXT
delay() can be called from user and kernel contexts. EXAMPLES
Example 1: delay() Example Before a driver I/O routine allocates buffers and stores any user data in them, it checks the status of the device (line 12). If the device needs manual intervention (such as, needing to be refilled with paper), a message is displayed on the system console (line 14). The driver waits an allotted time (line 17) before repeating the procedure. 1 struct device { /* layout of physical device registers */ 2 int control; /* physical device control word */ 3 int status; /* physical device status word */ 4 short xmit_char; /* transmit character to device */ 5 }; 6 7 . . . 9 /* get device registers */ 10 register struct device *rp = ... 11 12 while (rp->status & NOPAPER) { /* while printer is out of paper */ 13 /* display message and ring bell */ /* on system console */ 14 cmn_err(CE_WARN, "^07", 15 (getminor(dev) & 0xf)); 16 /* wait one minute and try again */ 17 delay(60 * drv_usectohz(1000000)); 18 } SEE ALSO
biodone(9F), biowait(9F), cv_timedwait(9F), ddi_in_panic(9F), drv_hztousec(9F), drv_usectohz(9F), drv_usecwait(9F), timeout(9F), untime- out(9F) Writing Device Drivers SunOS 5.10 15 Oct 2001 delay(9F)
Man Page