Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_periodic_delete(9f) [opensolaris man page]

ddi_periodic_delete(9F) 				   Kernel Functions for Drivers 				   ddi_periodic_delete(9F)

NAME
ddi_periodic_delete - cancel nanosecond periodic timeout requests SYNOPSIS
#include <sys/dditypes.h> #include <sys/sunddi.h> void ddi_periodic_delete(ddi_periodic_t req) INTERFACE LEVEL
Solaris DDI specific (Solaris DDI) PARAMETERS
req ddi_periodic_t opaque value returned by ddi_periodic_add(9F). DESCRIPTION
The ddi_periodic_delete() function cancels the ddi_periodic_add(9F) request that was previously issued. As with untimeout(9F), calling ddi_periodic_delete() against a periodic timeout request which is either running on another CPU, or has already been canceled causes no problems. Unlike untimeout(9F), there are no restrictions on the lock which might be held across the call to ddi_periodic_delete(). CONTEXT
The ddi_periodic_delete() function may be called from user or kernel context. EXAMPLES
Example 1 Cancelling a timeout request In the following example, the device driver cancels the timeout request by calling ddi_periodic_delete() against the request that was pre- viously issued. /* * Stop the periodic timer */ static void stop_periodic_timer(struct my_state *statep) { ddi_periodic_delete(statep->periodic_id); mutex_destory(&statep->lock); } static void start_periodic_timer(struct my_state *statep) { hrtime_t interval = CHECK_INTERVAL; mutex_init(&statep->lock, NULL, MUTEX_DRIVER, (void *)DDI_IPL_0); /* * Register my_callback which is invoked periodically * in CHECK_INTERVAL in kernel context. */ statep->periodic_id = ddi_periodic_add(my_periodic_func, statep, interval, DDI_IPL_0); } static void my_periodic_func(void *arg) { /* * This handler is invoked periodically. */ struct my_state *statep = (struct my_state *)arg; mutex_enter(&statep->lock); if (load_unbalanced(statep)) { balance_tasks(statep); } mutex_exit(&statep->lock); } SEE ALSO
cv_timedwait(9F), ddi_intr_get_pri(9F), ddi_periodic_add(9F), delay(9F), drv_usectohz(9F), qtimeout(9F), quntimeout(9F), timeout(9F), untimeout(9F) SunOS 5.11 2 Oct 2007 ddi_periodic_delete(9F)

Check Out this Related Man Page

untimeout(9F)						   Kernel Functions for Drivers 					     untimeout(9F)

NAME
untimeout - cancel previous timeout function call SYNOPSIS
#include <sys/types.h> #include <sys/conf.h> clock_t untimeout(timeout_id_t id); INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI). PARAMETERS
id Opaque timeout ID from a previous timeout(9F) call. DESCRIPTION
untimeout() cancels a pending timeout(9F) request. untimeout() will not return until the pending callback is cancelled or has run. Because of this, locks acquired by the callback routine should not be held across the call to untimeout() or a deadlock may result. Since no mutex should be held across the call to untimeout(), there is a race condition between the occurrence of an expected event and the execution of the timeout handler. In particular, it should be noted that no problems will result from calling untimeout() for a timeout which is either running on another CPU, or has already completed. Drivers should be structured with the understanding that the arrival of both an interrupt and a timeout for that interrupt can occasionally occur, in either order. RETURN VALUES
untimeout() returns -1 if the id is not found. Otherwise, it returns an integer value greater than or equal to 0. CONTEXT
untimeout() can be called from user or interrupt context. EXAMPLES
In the following example, the device driver has issued an IO request and is waiting for the device to respond. If the device does not respond within 5 seconds, the device driver will print out an error message to the console. static void xxtimeout_handler(void *arg) { struct xxstate *xsp = (struct xxstate *)arg; mutex_enter(&xsp->lock); cv_signal(&xsp->cv); xsp->flags |= TIMED_OUT; mutex_exit(&xsp->lock); xsp->timeout_id = 0; } static uint_t xxintr(caddr_t arg) { struct xxstate *xsp = (struct xxstate *)arg; . . . mutex_enter(&xsp->lock); /* Service interrupt */ cv_signal(&xsp->cv); mutex_exit(&xsp->lock); if (xsp->timeout_id != 0) { (void) untimeout(xsp->timeout_id); xsp->timeout_id = 0; } return(DDI_INTR_CLAIMED); } static void xxcheckcond(struct xxstate *xsp) { . . . xsp->timeout_id = timeout(xxtimeout_handler, xsp, (5 * drv_usectohz(1000000))); mutex_enter(&xsp->lock); while (/* Waiting for interrupt or timeout*/) cv_wait(&xsp->cv, &xsp->lock); if (xsp->flags & TIMED_OUT) cmn_err(CE_WARN, "Device not responding"); . . . mutex_exit(&xsp->lock); . . . } SEE ALSO
open(9E), cv_signal(9F), cv_wait_sig(9F), delay(9F), timeout(9F) Writing Device Drivers SunOS 5.10 18 Feb 1998 untimeout(9F)
Man Page