Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

ddi_enter_critical(9f) [opensolaris man page]

ddi_enter_critical(9F)					   Kernel Functions for Drivers 				    ddi_enter_critical(9F)

NAME
ddi_enter_critical, ddi_exit_critical - enter and exit a critical region of control SYNOPSIS
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> unsigned int ddi_enter_critical(void); void ddi_exit_critical(unsignedint ddic); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). PARAMETERS
ddic The returned value from the call to ddi_enter_critical() must be passed to ddi_exit_critical(). DESCRIPTION
Nearly all driver operations can be done without any special synchronization and protection mechanisms beyond those provided by, for exam- ple, mutexes (see mutex(9F)). However, for certain devices there can exist a very short critical region of code which must be allowed to run uninterrupted. The function ddi_enter_critical() provides a mechanism by which a driver can ask the system to guarantee to the best of its ability that the current thread of execution will neither be preempted nor interrupted. This stays in effect until a bracketing call to ddi_exit_critical() is made (with an argument which was the returned value from ddi_enter_critical()). The driver may not call any functions external to itself in between the time it calls ddi_enter_critical() and the time it calls ddi_exit_critical(). RETURN VALUES
The ddi_enter_critical() function returns an opaque unsigned integer which must be used in the subsequent call to ddi_exit_critical(). CONTEXT
This function can be called from user, interrupt, or kernel context. WARNINGS
Driver writers should note that in a multiple processor system this function does not temporarily suspend other processors from executing. This function also cannot guarantee to actually block the hardware from doing such things as interrupt acknowledge cycles. What it can do is guarantee that the currently executing thread will not be preempted. Do not write code bracketed by ddi_enter_critical() and ddi_exit_critical() that can get caught in an infinite loop, as the machine may crash if you do. SEE ALSO
mutex(9F) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_enter_critical(9F)

Check Out this Related Man Page

ddi_intr_get_hilevel_pri(9F)				   Kernel Functions for Drivers 			      ddi_intr_get_hilevel_pri(9F)

NAME
ddi_intr_get_hilevel_pri - get minimum priority level for a high-level interrupt SYNOPSIS
#include <sys/types.h> #include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_intr_get_hilevel_pri(void); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). DESCRIPTION
Upon a successful return, the ddi_intr_get_hilevel_pri() function returns the minimum priority level for a high-level interrupt. The return priority value can be used to compare to other priority values, such as those returned from ddi_intr_get_pri(9F), to determine if a given interrupt priority is a high-level interrupt. High-level interrupts must be handled without using system services that manipulate thread or process states, because such interrupts are not blocked by the scheduler. In addition, high-level interrupt handlers must take care to do a minimum of work because they cannot be preempted. A typical high-level interrupt handler puts data into a circular buffer and schedule a soft interrupt by calling ddi_intr_trigger_soft- int(). The circular buffer can be protected by using a mutex that is properly initialized for the interrupt handler. The ddi_intr_get_hilevel_pri() function can be used before calling ddi_intr_add_handler() to help determine which type of interrupt handler can be used. Most device drivers are designed with the knowledge that supported devices always generate low level interrupts. On some machines, however, interrupts are high-level above the scheduler level and on other machines they are not. Devices such as those those using SBus interrupts or VME bus level 6 or 7 interrupts must use the ddi_intr_get_hilevel_pri() function to test the type of interrupt handler that can be used. RETURN VALUES
The ddi_intr_get_hilevel_pri() function returns the priority value for a high-level interrupt. CONTEXT
The ddi_intr_get_hilevel_pri() function can be called from either user or kernel non-interrupt context. ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Interface Stability |Committed | +-----------------------------+-----------------------------+ SEE ALSO
attributes(5), ddi_intr_add_handler(9F), ddi_intr_alloc(9F), ddi_intr_enable(9F), ddi_intr_get_pri(9F), ddi_intr_trigger_softint(9F), mutex(9F) Writing Device Drivers SunOS 5.11 07 Apr 2005 ddi_intr_get_hilevel_pri(9F)
Man Page