Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_cs_ddi_info(9f) [opensolaris man page]

csx_CS_DDI_Info(9F)					   Kernel Functions for Drivers 				       csx_CS_DDI_Info(9F)

NAME
csx_CS_DDI_Info - obtain DDI information SYNOPSIS
#include <sys/pccard.h> int32_t csx_CS_DDI_Info(cs_ddi_info_t *cdi); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
cdi Pointer to a cs_ddi_info_t structure. DESCRIPTION
This function is a Solaris-specific extension that is used by clients that need to provide the xx_getinfo driver entry point (see get- info(9E)). It provides a method for clients to obtain DDI information based on their socket number and client driver name. STRUCTURE MEMBERS
The structure members of cs_ddi_info_t are: uint32_t Socket; /* socket number */ char* driver_name; /* unique driver name */ dev_info_t *dip; /* dip */ int32_t instance; /* instance */ The fields are defined as follows: Socket This field must be set to the physical socket number that the client is interested in getting information about. driver_name This field must be set to a string containing the name of the client driver to get information about. If csx_CS_DDI_Info() is used in a client's xx_getinfo function, then the client will typically extract the Socket value from the *arg argu- ment and it must set the driver_name field to the same string used with csx_RegisterClient(9F). If the driver_name is found on the Socket, the csx_CS_DDI_Info() function returns both the dev_info pointer and the instance fields for the requested driver instance. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_SOCKET Client not found on Socket. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. EXAMPLES
Example 1 : Using csx_CS_DDI_Info The following example shows how a client might call the csx_CS_DDI_Info() in the client's xx_getinfo function to return the dip or the instance number: static int pcepp_getinfo(dev_info_t *dip, ddi_info_cmd_t cmd, void *arg, void **result) { int error = DDI_SUCCESS; pcepp_state_t *pps; cs_ddi_info_t cs_ddi_info; switch (cmd) { case DDI_INFO_DEVT2DEVINFO: cs_ddi_info.Socket = getminor((dev_t)arg) & 0x3f; cs_ddi_info.driver_name = pcepp_name; if (csx_CS_DDI_Info(&cs_ddi_info) != CS_SUCCESS) return (DDI_FAILURE); if (!(pps = ddi_get_soft_state(pcepp_soft_state_p, cs_ddi_info.instance))) { *result = NULL; } else { *result = pps->dip; } break; case DDI_INFO_DEVT2INSTANCE: cs_ddi_info.Socket = getminor((dev_t)arg) & 0x3f; cs_ddi_info.driver_name = pcepp_name; if (csx_CS_DDI_Info(&cs_ddi_info) != CS_SUCCESS) return (DDI_FAILURE); *result = (void *)cs_ddi_info.instance; break; default: error = DDI_FAILURE; break; } return (error); } SEE ALSO
getinfo(9E), csx_RegisterClient(9F), ddi_get_instance(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 19 Jul 1996 csx_CS_DDI_Info(9F)

Check Out this Related Man Page

getinfo(9E)							Driver Entry Points						       getinfo(9E)

NAME
getinfo - get device driver information SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int prefixgetinfo(dev_info_t *dip, ddi_info_cmd_t cmd, void *arg, void **resultp); INTERFACE LEVEL
Solaris DDI specific (Solaris DDI). This entry point is required for drivers which export cb_ops(9S) entry points. ARGUMENTS
dip Do not use. cmd Command argument - valid command values are DDI_INFO_DEVT2DEVINFO and DDI_INFO_DEVT2INSTANCE. arg Command specific argument. resultp Pointer to where the requested information is stored. DESCRIPTION
When cmd is set to DDI_INFO_DEVT2DEVINFO, getinfo() should return the dev_info_t pointer associated with the dev_t arg. The dev_info_t pointer should be returned in the field pointed to by resultp. When cmd is set to DDI_INFO_DEVT2INSTANCE, getinfo() should return the instance number associated with the dev_t arg. The instance number should be returned in the field pointed to by resultp. Drivers which do not export cb_ops(9S) entry points are not required to provide a getinfo() entry point, and may use nodev(9F) in the devo_getinfo field of the dev_ops(9S) structure. A SCSI HBA driver is an example of a driver which is not required to provide cb_ops(9S) entry points. RETURN VALUES
getinfo() should return: DDI_SUCCESS on success. DDI_FAILURE on failure. EXAMPLES
Example 1 getinfo() implementation /*ARGSUSED*/ static int rd_getinfo(dev_info_t *dip, ddi_info_cmd_t infocmd, void *arg, void **resultp) { /* Note that in this simple example * the minor number is the instance * number. */ devstate_t *sp; int error = DDI_FAILURE; switch (infocmd) { case DDI_INFO_DEVT2DEVINFO: if ((sp = ddi_get_soft_state(statep, getminor((dev_t) arg))) != NULL) { *resultp = sp->devi; error = DDI_SUCCESS; } else *result = NULL; break; case DDI_INFO_DEVT2INSTANCE: *resultp = (void *) (uintptr_t) getminor((dev_t) arg); error = DDI_SUCCESS; break; } return (error); } SEE ALSO
ddi_no_info(9F), nodev(9F), cb_ops(9S), dev_ops(9S) Writing Device Drivers NOTES
Non-gld(7D)-based DLPI network streams drivers are encouraged to switch to gld(7D). Failing this, a driver that creates DLPI style-2 minor nodes must specify CLONE_DEV for its style-2 ddi_create_minor_node(9F) nodes and use qassociate(9F). A driver that supports both style-1 and style-2 minor nodes should return DDI_FAILURE for DDI_INFO_DEVT2INSTANCE and DDI_INFO_DEVT2DEVINFO getinfo() calls to style-2 minor nodes. (The correct association is already established by qassociate(9F)). A driver that only supports style-2 minor nodes can use ddi_no_info(9F) for its getinfo() implementation. For drivers that do not follow these rules, the results of a modunload(1M) of the driver or a cfgadm(1M) remove of hardware controlled by the driver are undefined. SunOS 5.11 16 Jan 2008 getinfo(9E)
Man Page