Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_parse_cistpl_funcid(9f) [opensolaris man page]

csx_Parse_CISTPL_FUNCID(9F)				   Kernel Functions for Drivers 			       csx_Parse_CISTPL_FUNCID(9F)

NAME
csx_Parse_CISTPL_FUNCID - parse Function Identification tuple SYNOPSIS
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_FUNCID(client_handle_t ch, tuple_t *tu, cistpl_funcid_t *cf); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). tu Pointer to a tuple_t structure (see tuple(9S)) returned by a call to csx_GetFirstTuple(9F) or csx_GetNextTuple(9F). cf Pointer to a cistpl_funcid_t structure which contains the parsed CISTPL_FUNCID tuple information upon return from this function. DESCRIPTION
This function parses the Function Identification tuple, CISTPL_FUNCID, into a form usable by PC Card drivers. The CISTPL_FUNCID tuple is used to describe information about the functionality provided by a PC Card. Information is also provided to enable system utilities to decide if the PC Card should be configured during system initialization. If additional function specific infor- mation is available, one or more function extension tuples of type CISTPL_FUNCE follow this tuple (see csx_Parse_CISTPL_FUNCE(9F)). STRUCTURE MEMBERS
The structure members of cistpl_funcid_t are: uint32_t function; /* PC Card function code */ uint32_t sysinit; /* system initialization mask */ The fields are defined as follows: function This is the function type for CISTPL_FUNCID: TPLFUNC_MULTI Vendor-specific multifunction card TPLFUNC_MEMORY Memory card TPLFUNC_SERIAL Serial I/O port TPLFUNC_PARALLEL Parallel printer port TPLFUNC_FIXED Fixed disk, silicon or removable TPLFUNC_VIDEO Video interface TPLFUNC_LAN Local Area Network adapter TPLFUNC_AIMS Auto Incrementing Mass Storage TPLFUNC_SCSI SCSI bridge TPLFUNC_SECURITY Security cards TPLFUNC_VENDOR_SPECIFIC Vendor specific TPLFUNC_UNKNOWN Unknown function(s) sysinit This field is bit-mapped and defined as follows: TPLINIT_POST POST should attempt configure TPLINIT_ROM Map ROM during sys init RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_UNKNOWN_TUPLE Parser does not know how to parse tuple. CS_NO_CARD No PC Card in socket. CS_NO_CIS No Card Information Structure (CIS) on PC Card. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_GetFirstTuple(9F), csx_GetTupleData(9F), csx_Parse_CISTPL_FUNCE(9F), csx_RegisterClient(9F), csx_ValidateCIS(9F), tuple(9S) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 20 Dec 1996 csx_Parse_CISTPL_FUNCID(9F)

Check Out this Related Man Page

csx_Parse_CISTPL_LINKTARGET(9F) 			   Kernel Functions for Drivers 			   csx_Parse_CISTPL_LINKTARGET(9F)

NAME
csx_Parse_CISTPL_LINKTARGET - parse the Link Target tuple SYNOPSIS
#include <sys/pccard.h> int32_t csx_Parse_CISTPL_LINKTARGET(client_handle_t ch, tuple_t *tu, cistpl_linktarget_t *pt); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). tu Pointer to a tuple_t structure (see tuple(9S)) returned by a call to csx_GetFirstTuple(9F) or csx_GetNextTuple(9F). pt Pointer to a cistpl_linktarget_t structure which contains the parsed CISTPL_LINKTARGET tuple information upon return from this func- tion. DESCRIPTION
This function parses the Link Target tuple, CISTPL_LINKTARGET, into a form usable by PCCard drivers. The CISTPL_LINKTARGET tuple is used to verify that tuple chains other than the primary chain are valid. All secondary tuple chains are required to contain this tuple as the first tuple of the chain. STRUCTURE MEMBERS
The structure members of cistpl_linktarget_t are: uint32_t length; char tpltg_tag[CIS_MAX_TUPLE_DATA_LEN]; The fields are defined as follows: length This field indicates the number of bytes in tpltg_tag. tpltg_tag This field provides the Link Target tuple information. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid. CS_UNKNOWN_TUPLE Parser does not know how to parse tuple. CS_NO_CARD No PC Card in socket. CS_NO_CIS No Card Information Structure (CIS) on PC Card. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_GetFirstTuple(9F), csx_GetTupleData(9F), csx_RegisterClient(9F), csx_ValidateCIS(9F), tuple(9S) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 24 Jan 1997 csx_Parse_CISTPL_LINKTARGET(9F)
Man Page