Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

csx_modifywindow(9f) [opensolaris man page]

csx_ModifyWindow(9F)					   Kernel Functions for Drivers 				      csx_ModifyWindow(9F)

NAME
csx_ModifyWindow - modify window attributes SYNOPSIS
#include <sys/pccard.h> int32_t csx_ModifyWindow(window_handle_t wh, modify_win_t *mw); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
wh Window handle returned from csx_RequestWindow(9F). mw Pointer to a modify_win_t structure. DESCRIPTION
This function modifies the attributes of a window allocated by the csx_RequestWindow(9F) function. Only some of the window attributes or the access speed field may be modified by this request. The csx_MapMemPage(9F) function is also used to set the offset into PC Card memory to be mapped into system memory for paged windows. The csx_RequestWindow(9F) and csx_ReleaseWin- dow(9F) functions must be used to change the window base or size. STRUCTURE MEMBERS
The structure members of modify_win_t are: uint32_t Attributes; /* window flags */ uint32_t AccessSpeed; /* window access speed */ The fields are defined as follows: Attributes This field is bit-mapped and defined as follows: WIN_MEMORY_TYPE_CM Window points to Common Memory area. Set this to map the window to Common Memory. WIN_MEMORY_TYPE_AM Window points to Attribute Memory area. Set this to map the window to Attribute Memory. WIN_ENABLE Enable Window. The client must set this to enable the window. WIN_ACCESS_SPEED_VALID AccessSpeed valid. The client must set this when the AccessSpeed field has a value that the client wants set for the window. AccessSpeed The bit definitions for this field use the format of the extended speed byte of the Device ID tuple. If the mantissa is 0 (noted as reserved in the PC Card 95 Standard), the lower bits are a binary code representing a speed from the list below. Numbers in the first column are codes; items in the second column are speeds. 0 Reserved: do not use 1 250 nsec 2 200 nsec 3 150 nsec 4 100 nsec 5 - 7 Reserved: do not use It is recommended that clients use the csx_ConvertSpeed(9F) function to generate the appropriate AccessSpeed values rather than manually perturbing the AccessSpeed field. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Window handle is invalid. CS_NO_CARD No PC Card in socket. CS_BAD_OFFSET Error getting/setting window hardware parameters. CS_BAD_WINDOW Error getting/setting window hardware parameters. CS_BAD_SPEED AccessSpeed is invalid. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_ConvertSpeed(9F), csx_MapMemPage(9F), csx_ReleaseWindow(9F), csx_RequestWindow(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.11 19 Jul 1996 csx_ModifyWindow(9F)

Check Out this Related Man Page

csx_ReleaseConfiguration(9F)				   Kernel Functions for Drivers 			      csx_ReleaseConfiguration(9F)

NAME
csx_ReleaseConfiguration - release PC Card and socket configuration SYNOPSIS
#include <sys/pccard.h> int32_t csx_ReleaseConfiguration(client_handle_t ch, release_config_t *rc); INTERFACE LEVEL
Solaris DDI Specific (Solaris DDI) PARAMETERS
ch Client handle returned from csx_RegisterClient(9F). rc Pointer to a release_config_t structure. DESCRIPTION
This function returns a PC Card and socket to a simple memory only interface and sets the card to configuration zero by writing a 0 to the PC card's COR (Configuration Option Register). Card Services may remove power from the socket if no clients have indicated their usage of the socket by an active csx_RequestConfigura- tion(9F) or csx_RequestWindow(9F). Card Services is prohibited from resetting the PC Card and is not required to cycle power through zero(0) volts. After calling csx_ReleaseConfiguration() any resources requested via the request functions csx_RequestIO(9F), csx_RequestIRQ(9F), or csx_RequestWindow(9F) that are no longer needed should be returned to Card Services via the corresponding csx_ReleaseIO(9F), csx_Relea- seIRQ(9F), or csx_ReleaseWindow(9F) functions. csx_ReleaseConfiguration() must be called to release the current card and socket configura- tion before releasing any resources requested by the driver via the request functions named above. STRUCTURE MEMBERS
The structure members of release_config_t are: uint32_t Socket; /* socket number */ The Socket field is not used in Solaris, but for portability with other Card Services implementations, it should be set to the logical socket number. RETURN VALUES
CS_SUCCESS Successful operation. CS_BAD_HANDLE Client handle is invalid or csx_RequestConfiguration(9F) not done. CS_BAD_SOCKET Error getting or setting socket hardware parameters. CS_NO_CARD No PC card in socket. CS_UNSUPPORTED_FUNCTION No PCMCIA hardware installed. CONTEXT
This function may be called from user or kernel context. SEE ALSO
csx_RegisterClient(9F), csx_RequestConfiguration(9F), csx_RequestIO(9F), csx_RequestIRQ(9F), csx_RequestWindow(9F) PC Card 95 Standard, PCMCIA/JEIDA SunOS 5.10 19 Jul 1996 csx_ReleaseConfiguration(9F)
Man Page