datab(9S) Data Structures for Drivers datab(9S)NAME
datab, dblk - STREAMS message data structure
Architecture independent level 1 (DDI/DKI).
The datab structure describes the data of a STREAMS message. The actual data contained in a STREAMS message is stored in a data buffer
pointed to by this structure. A msgb (message block) structure includes a field that points to a datab structure.
Because a data block can have more than one message block pointing to it at one time, the db_ref member keeps track of a data block's ref-
erences, preventing it from being deallocated until all message blocks are finished with it.
unsigned char *db_base; /* first byte of buffer */
unsigned char *db_lim; /* last byte (+1) of buffer */
unsigned char db_ref; /* # of message pointers to this data */
unsigned char db_type; /* message type */
A datab structure is defined as type dblk_t.
SEE ALSO free_rtn(9S), msgb(9S)
Writing Device Drivers
STREAMS Programming Guide
SunOS 5.11 24 Oct 2003 datab(9S)
Check Out this Related Man Page
msgb(9S) Data Structures for Drivers msgb(9S)NAME
msgb, mblk - STREAMS message block structure
Architecture independent level 1 (DDI/DKI)
A STREAMS message is made up of one or more message blocks, referenced by a pointer to a msgb structure. The b_next and b_prev pointers
are used to link messages together on a QUEUE. The b_cont pointer links message blocks together when a message consists of more than one
Each msgb structure also includes a pointer to a datab(9S) structure, the data block (which contains pointers to the actual data of the
message), and the type of the message.
struct msgb *b_next; /* next message on queue */
struct msgb *b_prev; /* previous message on queue */
struct msgb *b_cont; /* next message block */
unsigned char *b_rptr; /* 1st unread data byte of buffer */
unsigned char *b_wptr; /* 1st unwritten data byte of buffer */
struct datab *b_datap; /* pointer to data block */
unsigned char b_band; /* message priority */
unsigned short b_flag; /* used by stream head */
Valid flags are as follows:
MSGMARK Last byte of message is marked.
MSGDELIM Message is delimited.
The msgb structure is defined as type mblk_t.
SEE ALSO datab(9S)
Writing Device Drivers
STREAMS Programming Guide
SunOS 5.10 11 Apr 1991 msgb(9S)
:cool: I like Vibhory2 like the idea of tapping into the kernel.. although not as indepth as he/she... i want to create a virtual databse of a few ma chines with connectivity and defiinte knowledge to create it.. I havebeen working on the project for a year now.. ! before unix (1 year exactly) i... (20 Replies)
I am trying to connect to Oracle Databse from UNIX box using sqlplus command. But i get sqplus not found message.
sqlplus: not found
I have searched in forums and all are suggesting to set environment varaibles...can somebody tell me what variables to set and how to set.and the... (12 Replies)
I am new to the shell scripting basically.I have been asked to create a shell script that connect to a oracle database to read data from a particular schema then spool it into a csv file then email to customer.
Can anybody let me know how to go about that.
I have create... (14 Replies)
I'm wondering about the best way to store large amounts of sorted data, sorted by date/time, in a manner to allow fast retrieval of ranges of dates. Deletion isn't necessary.
A database hardly seems ideal, since they're not optimized for sorted data, and allow things I don't need like the... (18 Replies)
How can I know if ORACLE Database is running slow due to Memory or due to processing power ?
I have only Oracle Database running on a P4 with 4GB RAM.
Could anyone suggest any tools which can help me determine exactly if it is memory issue or processor issue. (43 Replies)
Enclosed is comma separated text file. I need to write a korn shell program that will parse the text file and insert the values into Oracle database.
I need to write the korn shell program on Red Hat Enterprise Linux server.
Oracle database is 10g. (15 Replies)
Hey, I have this basic server thing going on and I can't seem to allocate
memory correctly and I can't access the memory after I allocated it. I
was hoping people might suggest methods of doing this. I was thinking of
using the socket file descriptor to reference the users. (14 Replies)
Can I make Mailx to read recipient address from a mysql database?
I already tried emailing with bash script:
export EMAIL_ADDRESS=`mysql -uroot -pabcde smsd -e "SELECT email FROM recipient"`
mysql -uroot -pabcde smsd -e "SELECT ID, SenderName, Body FROM inbox" |... (14 Replies)
Hello All Members,
I am new to this forum and to the shell scripting. I want to write a shell script to do the following:
Scenario: I have a pipe delimited .txt file with multiple fields in it. The very first row of the file contains the name of the column which resembles the name of the... (18 Replies)
I have a log file that's created daily by this command:
sar -u 300 288 >> /var/log/usage/$(date "+%Y-%m-%d")_$(hostname)_cpu.log
It that contains data like this:
Linux 3.16.0-4-amd64 (myhostname) 08/15/2015 _x86_64_ (1 CPU)
11:34:17 PM CPU %user %nice ... (12 Replies)
Discussion started by: unplugme71
12. Post Here to Contact Site Administrators and Moderators
Hi, Just wanting to know if there is any issues today with the site. Initially I thought it is my internet connection or computer but regardless which one I use, the site has been slow and it is also not showing with the right fonts etc. I've been trying for the last 12+ hours and it's always been... (21 Replies)
I'm a junior programmer. This is my first post here, please excuse me if that's not the correct place :)
For days now I've been trying to install Oracle DB 12c R2 on Ubuntu 18.04. I'm at my wits' end. The software itself installs fine and a Listener can be started but I can't start... (15 Replies)
Just restarted MySQL a few times.
There seems to be a problem with MySQL performance because one table (our man page table) is too large and I need to move that table to a new database and out of the main forums DB.
That table is over 7 GB, bigger than the rest of the DB combined:
... (14 Replies)