opensolaris man page for datab

Query: datab

OS: opensolaris

Section: 9s

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

datab(9S)						    Data Structures for Drivers 						 datab(9S)

NAME
datab, dblk - STREAMS message data structure
SYNOPSIS
#include <sys/stream.h>
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
DESCRIPTION
The datab structure describes the data of a STREAMS message. The actual data contained in a STREAMS message is stored in a data buffer pointed to by this structure. A msgb (message block) structure includes a field that points to a datab structure. Because a data block can have more than one message block pointing to it at one time, the db_ref member keeps track of a data block's ref- erences, preventing it from being deallocated until all message blocks are finished with it.
STRUCTURE MEMBERS
unsigned char *db_base; /* first byte of buffer */ unsigned char *db_lim; /* last byte (+1) of buffer */ unsigned char db_ref; /* # of message pointers to this data */ unsigned char db_type; /* message type */ A datab structure is defined as type dblk_t.
SEE ALSO
free_rtn(9S), msgb(9S) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 24 Oct 2003 datab(9S)
Related Man Pages
mblk(9s) - sunos
msgb(9s) - php
msgb(9s) - minix
msgb(9s) - suse
msgb(9s) - mojave
Similar Topics in the Unix Linux Community
trying to create a virtual database..
How to COnnect to Oracle database from UNIX Box
data is seen as NULL after loading into database
Mailx recipient from mysql database
Parse log file to insert into database