opensolaris man page for scsi_destroy_pkt

Query: scsi_destroy_pkt

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

scsi_destroy_pkt(9F)					   Kernel Functions for Drivers 				      scsi_destroy_pkt(9F)

NAME
scsi_destroy_pkt - free an allocated SCSI packet and its DMA resource
SYNOPSIS
#include <sys/scsi/scsi.h> void scsi_destroy_pkt(struct scsi_pkt *pktp);
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
PARAMETERS
pktp Pointer to a scsi_pkt(9S) structure.
DESCRIPTION
The scsi_destroy_pkt() function releases all necessary resources, typically at the end of an I/O transfer. The data is synchronized to mem- ory, then the DMA resources are deallocated and pktp is freed.
CONTEXT
The scsi_destroy_pkt() function may be called from user, interrupt, or kernel context.
EXAMPLES
Example 1 Releasing resources scsi_destroy_pkt(un->un_rqs);
SEE ALSO
tran_destroy_pkt(9E), scsi_init_pkt(9F), scsi_pkt(9S) Writing Device Drivers SunOS 5.11 16 Jan 2006 scsi_destroy_pkt(9F)
Related Man Pages
scsi_sync_pkt(9f) - opensolaris
scsi_sync_pkt(9f) - debian
scsi_dmaget(9f) - suse
scsi_dmaget(9f) - centos
scsi_sync_pkt(9f) - suse
Similar Topics in the Unix Linux Community
Trying to block signal
What does this mean?
Study UNIX Kernel
%memused is high
Shopt -s histappend