Query: putctl1
OS: opensolaris
Section: 9f
Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar
putctl1(9F) Kernel Functions for Drivers putctl1(9F)NAMEputctl1 - send a control message with a one-byte parameter to a queueSYNOPSIS#include <sys/stream.h> int putctl1(queue_t *q, int type, int p);INTERFACE LEVELArchitecture independent level 1 (DDI/DKI).PARAMETERSq Queue to which the message is to be sent. type Type of message. p One-byte parameter.DESCRIPTIONThe putctl1() function, like putctl(9F), tests the type argument to make sure a data type has not been specified, and attempts to allocate a message block. The p parameter can be used, for example, to specify how long the delay will be when an M_DELAY message is being sent. putctl1() fails if type is M_DATA, M_PROTO, or M_PCPROTO, or if a message block cannot be allocated. If successful, putctl1() calls the put(9E) routine of the queue pointed to by q with the newly allocated and initialized message.RETURN VALUESOn success, 1 is returned. 0 is returned if type is a data type, or if a message block cannot be allocated.CONTEXTThe putctl1() function can be called from user, interrupt, or kernel context.EXAMPLESSee the putctl(9F) function page for an example of putctl1().SEE ALSOput(9E), allocb(9F), datamsg(9F), putctl(9F), putnextctl1(9F) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 16 Jan 2006 putctl1(9F)
Related Man Pages |
---|
putctl1(9f) - centos |
putctl1(9f) - php |
putctl1(9f) - osx |
putctl1(9f) - linux |
putctl1(9f) - v7 |
Similar Topics in the Unix Linux Community |
---|
POSIX Message Queue Memory Allocation |