opensolaris man page for gethrtime

Query: gethrtime

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

gethrtime(9F)						   Kernel Functions for Drivers 					     gethrtime(9F)

NAME
gethrtime - get high resolution time
SYNOPSIS
#include <sys/time.h> hrtime_t gethrtime(void);
DESCRIPTION
The gethrtime() function returns the current high-resolution real time. Time is expressed as nanoseconds since some arbitrary time in the past; it is not correlated in any way to the time of day, and thus is not subject to resetting or drifting by way of adjtime(2) or settime- ofday(3C). The hi-res timer is ideally suited to performance measurement tasks, where cheap, accurate interval timing is required.
RETURN VALUES
gethrtime() always returns the current high-resolution real time. There are no error conditions.
CONTEXT
There are no restrictions on the context from which gethrtime() can be called.
SEE ALSO
proc(1), gettimeofday(3C), settimeofday(3C), attributes(5)
NOTES
Although the units of hi-res time are always the same (nanoseconds), the actual resolution is hardware dependent. Hi-res time is guaranteed to be monotonic (it does not go backward, it does not periodically wrap) and linear (it does not occasionally speed up or slow down for adjustment, as the time of day can), but not necessarily unique: two sufficiently proximate calls might return the same value. The time base used for this function is the same as that for gethrtime(3C). Values returned by both of these functions can be interleaved for comparison purposes. SunOS 5.11 2 Oct 2007 gethrtime(9F)
Related Man Pages
gethrtime(3c) - opensolaris
gethrvtime(3c) - opensolaris
gethrtime(9f) - sunos
gethrtime(3c) - osx
gethrtime(3c) - suse
Similar Topics in the Unix Linux Community
time function
Globulation 2 0.9.4 (Default branch)
Why iris scanning can be a biometric
How do I slow down a process?
what would a script include to find CPU's %system time high and user time high?