opensolaris man page for dupmsg

Query: dupmsg

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

dupmsg(9F)						   Kernel Functions for Drivers 						dupmsg(9F)

NAME
dupmsg - duplicate a message
SYNOPSIS
#include <sys/stream.h> mblk_t *dupmsg(mblk_t *mp);
INTERFACE LEVEL
Architecture independent level 1 (DDI/DKI).
PARAMETERS
mp Pointer to the message.
DESCRIPTION
dupmsg() forms a new message by copying the message block descriptors pointed to by mp and linking them. dupb(9F) is called for each mes- sage block. The data blocks themselves are not duplicated.
RETURN VALUES
If successful, dupmsg() returns a pointer to the new message block. Otherwise, it returns a NULL pointer. A return value of NULL indi- cates either memory depletion or the data block reference count, db_ref (see datab(9S)), has reached a limit(255). See dupb(9F).
CONTEXT
dupmsg() can be called from user, kernel, or interrupt context.
EXAMPLES
Example 1 Using dupmsg() See copyb(9F) for an example using dupmsg().
SEE ALSO
copyb(9F), copymsg(9F), dupb(9F), datab(9S) Writing Device Drivers STREAMS Programming Guide SunOS 5.11 11 Apr 1991 dupmsg(9F)
Related Man Pages
copyb(9f) - sunos
copyb(9f) - php
dupmsg(9f) - php
copyb(9f) - redhat
dupmsg(9f) - hpux
Similar Topics in the Unix Linux Community
PHP Man Pages Now Available (Over 10,000)
Study UNIX Kernel
What's legal and what's not?
Identify problem with while getopts
What is good?