opensolaris man page for ddi_dma_mem_free

Query: ddi_dma_mem_free

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_dma_mem_free(9F)					   Kernel Functions for Drivers 				      ddi_dma_mem_free(9F)

NAME
ddi_dma_mem_free - free previously allocated memory
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> void ddi_dma_mem_free(ddi_acc_handle_t *handlep);
PARAMETERS
handlep Pointer to the data access handle previously allocated by a call to ddi_dma_mem_alloc(9F).
INTERFACE LEVEL
Solaris DDI specific (Solaris DDI).
DESCRIPTION
ddi_dma_mem_free() deallocates the memory acquired by ddi_dma_mem_alloc(9F). In addition, it destroys the data access handle handlep asso- ciated with the memory.
CONTEXT
ddi_dma_mem_free() can be called from user, kernel, or interrupt context.
SEE ALSO
ddi_dma_mem_alloc(9F) Writing Device Drivers SunOS 5.11 26 Sep 1994 ddi_dma_mem_free(9F)
Related Man Pages
ddi_dma_mem_alloc(9f) - sunos
ddi_iopb_alloc(9f) - centos
ddi_iopb_alloc(9f) - minix
ddi_iopb_alloc(9f) - hpux
ddi_iopb_alloc(9f) - suse
Similar Topics in the Unix Linux Community
Trying to block signal
solaris zones vs container..
Study UNIX Kernel
Free Sun Blade 2k, Ultra 2, Ross Hyperstation 30, cards, memory- Baltimore, MD
Identify problem with while getopts