opensolaris man page for ddi_dma_free

Query: ddi_dma_free

OS: opensolaris

Section: 9f

Format: Original Unix Latex Style Formatted with HTML and a Horizontal Scroll Bar

ddi_dma_free(9F)					   Kernel Functions for Drivers 					  ddi_dma_free(9F)

NAME
ddi_dma_free - release system DMA resources
SYNOPSIS
#include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_free(ddi_dma_handle_t handle);
INTERFACE LEVEL
This interface is obsolete. ddi_dma_free_handle(9F) should be used instead.
PARAMETERS
handle The handle filled in by a call to ddi_dma_setup(9F).
DESCRIPTION
The ddi_dma_free() function releases system DMA resources set up by ddi_dma_setup(9F). When a DMA transfer completes, the driver should free up system DMA resources established by a call to ddi_dma_setup(9F). This is done by a call to ddi_dma_free(). ddi_dma_free() does an implicit ddi_dma_sync(9F) for you so any further synchronization steps are not necessary.
RETURN VALUES
The ddi_dma_free() function returns: DDI_SUCCESS Successfully released resources DDI_FAILURE Failed to free resources
CONTEXT
The ddi_dma_free() function can be called from user, interrupt, or kernel context.
ATTRIBUTES
See attributes(5) for a description of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Stability Level |Obsolete | +-----------------------------+-----------------------------+
SEE ALSO
attributes(5), ddi_dma_addr_setup(9F), ddi_dma_buf_setup(9F), ddi_dma_free_handle(9F), ddi_dma_htoc(9F), ddi_dma_sync(9F), ddi_dma_req(9S) Writing Device Drivers SunOS 5.11 16 Jan 2006 ddi_dma_free(9F)
Related Man Pages
ddi_dma_buf_setup(9f) - sunos
ddi_dma_setup(9f) - centos
ddi_dma_setup(9f) - linux
ddi_dma_setup(9f) - xfree86
ddi_dma_setup(9f) - hpux
Similar Topics in the Unix Linux Community
solaris zones vs container..
Study UNIX Kernel
Grep the 'not running' jobs and will send the update in mail with its name(job)
Identify problem with while getopts
Shopt -s histappend