Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

sockio(7i) [opensolaris man page]

sockio(7I)							  Ioctl Requests							sockio(7I)

NAME
sockio - ioctls that operate directly on sockets SYNOPSIS
#include <sys/sockio.h> DESCRIPTION
The ioctls listed in this manual page apply directly to sockets, independent of any underlying protocol. The setsockopt() call (see get- sockopt(3SOCKET)) is the primary method for operating on sockets, rather than on the underlying protocol or network interface. ioctls for a specific network interface or protocol are documented in the manual page for that interface or protocol. SIOCSPGRP The argument is a pointer to an int. Set the process-group ID that will subsequently receive SIGIO or SIGURG signals for the socket referred to by the descriptor passed to ioctl to the value of that int. The argument must be either positive (in which case it must be a process ID) or negative (in which case it must be a process group). SIOCGPGRP The argument is a pointer to an int. Set the value of that int to the process-group ID that is receiving SIGIO or SIGURG signals for the socket referred to by the descriptor passed to ioctl. SIOCCATMARK The argument is a pointer to an int. Set the value of that int to 1 if the read pointer for the socket referred to by the descriptor passed to ioctl points to a mark in the data stream for an out-of-band message. Set the value of that int to 0 if the read pointer for the socket referred to by the descriptor passed to ioctl does not point to a mark in the data stream for an out-of-band message. SEE ALSO
ioctl(2), getsockopt(3SOCKET) SunOS 5.11 8 Nov 1996 sockio(7I)

Check Out this Related Man Page

sockatmark(3N)															    sockatmark(3N)

NAME
sockatmark() - determine whether a socket is at the out-of-band mark SYNOPSIS
DESCRIPTION
The function determines whether the socket specified by the descriptor is at the out-of-band data mark. If the protocol for the socket supports out-of-band data by marking the stream with an out-of-band mark, the function returns 1 when all data preceding the mark has been read and the out-of-band mark is the first element in the receive queue. The function does not remove the mark from the stream. X/Open Sockets Only is new in RETURN VALUES
Upon successful completion, the function returns a value indicating whether the socket is at an out-of-band data mark: If the protocol has marked the data stream and all data preceding the mark has been read. If there is no mark, or if data precedes the mark in the receive queue. On failure, returns and sets to indicate the error. ERRORS
If fails, is set to one of the following values: The argument is not a valid file descriptor. The argument does not specify a descriptor for a socket. APPLICATION USAGE
The use of this function between receive operations allows an application to determine which received data precedes the out-of-band data and which follows the out-of-band data. There is an inherent race condition in the use of this function. On an empty receive queue, the current read of the location might be at the "mark". However, the system has no way of knowing that the next data segment arriving from the network is carrying the mark. Then returns false, and the next read operation silently consumes the mark. Hence, this function can only be used reliably in one or both ways: o when the application already knows that the out-of-band data has been seen by the system o and that it knows data is waiting to be read at the socket (by using or AUTHOR
was developed by HP and IEEE. SEE ALSO
ioctl(2), pselect(2), recv(2), recvmsg(2), socket(7). STANDARDS CONFORMANCE
sockatmark(3N)
Man Page