Linux and UNIX Man Pages

Linux & Unix Commands - Search Man Pages

fbio(7i) [opensolaris man page]

fbio(7I)							  Ioctl Requests							  fbio(7I)

NAME
fbio - frame buffer control operations DESCRIPTION
The frame buffers provided with this release support the same general interface that is defined by <sys/fbio.h>. Each responds to an FBIOG- TYPE ioctl(2) request which returns information in a fbtype structure. Each device has an FBTYPE which is used by higher-level software to determine how to perform graphics functions. Each device is used by opening it, doing an FBIOGTYPE ioctl() to see which frame buffer type is present, and thereby selecting the appropriate device-management routines. FBIOGINFO returns information specific to the GS accelerator. FBIOSVIDEO and FBIOGVIDEO are general-purpose ioctl() requests for controlling possible video features of frame buffers. These ioctl() requests either set or return the value of a flags integer. At this point, only the FBVIDEO_ON option is available, controlled by FBIOSVIDEO. FBIOGVIDEO returns the current video state. The FBIOSATTR and FBIOGATTR ioctl() requests allow access to special features of newer frame buffers. They use the fbsattr and fbgattr structures. Some color frame buffers support the FBIOPUTCMAP and FBIOGETCMAP ioctl() requests, which provide access to the colormap. They use the fbcmap structure. Also, some framebuffers with multiple colormaps will either encode the colormap identifier in the high-order bits of the "index" field in the fbcmap structure, or use the FBIOPUTCMAPI and FBIOGETCMAPI ioctl() requests. FBIOVERTICAL is used to wait for the start of the next vertical retrace period. FBIOVRTOFFSET Returns the offset to a read-only vertical retrace page for those framebuffers that support it. This vertical retrace page may be mapped into user space with mmap(2). The first word of the vertical retrace page (type unsigned int) is a counter that is incre- mented every time there is a vertical retrace. The user process can use this counter in a variety of ways. FBIOMONINFO returns a mon_info structure which contains information about the monitor attached to the framebuffer, if available. FBIOSCURSOR, FBIOGCURSOR, FBIOSCURPOS and FBIOGCURPOS are used to control the hardware cursor for those framebuffers that have this fea- ture. FBIOGCURMAX returns the maximum sized cursor supported by the framebuffer. Attempts to create a cursor larger than this will fail. Finally FBIOSDEVINFO and FBIOGDEVINFO are used to transfer variable-length, device-specific information into and out of framebuffers. SEE ALSO
ioctl(2), mmap(2), cgsix(7D) BUGS
The FBIOSATTR and FBIOGATTR ioctl() requests are only supported by frame buffers which emulate older frame buffer types. If a frame buffer emulates another frame buffer, FBIOGTYPE returns the emulated type. To get the real type, use FBIOGATTR. The FBIOGCURPOS ioctl was incorrectly defined in previous operating systems, and older code running in binary compatibility mode may get incorrect results. SunOS 5.11 12 May 2003 fbio(7I)

Check Out this Related Man Page

sesio(7I)							  Ioctl Requests							 sesio(7I)

NAME
sesio - enclosure services device driver interface SYNOPSIS
#include <sys/sesio.h> DESCRIPTION
The ses device driver provides the following ioctls as a means to access SCSI enclosure services devices. IOCTLS
The ses driver supports the following ioctls: SES_IOCTL_GETSTATE This ioctl obtains enclosure state in the ses_ioctl structure. SES_IOCTL_SETSTATE This ioctl is used to set parameters on the enclosure services device. The ses_ioctl structure is used to pass information into the driver. ERRORS
EIO The ses driver was unable to obtain data from the enclosure services device or the data transfer could not be completed. ENOTTY The ses driver does not support the requested ioctl function. ENXIO The enclosure services device does not exist. EFAULT The user specified a bad data length. STRUCTURES
The ses_ioctl structure has the following fields: uint32_t; /* Size of buffer that follows */ uint8_t page_code: /* Page to be read/written */ uint8_t reserved[3]; /* Reserved; Set to 0 */ unit8t buffer[1]; /* Size arbitrary, user specifies */ EXAMPLES
Example 1 Using the SES_IOCTL_GETSTATE ioctl The following example uses the SES_IOCTL_GETSTATE ioctl to recover 20 bytes of page 4 from a previously opened device. char abuf[30]; struct ses_ioctl *sesp; int status; sesp = (ses_ioctl *)abuf; sesp->size = 20; sesp->page_code = 4; status = ioctl(fd, SES_IOCTL_GETSTATE, abuf); ATTRIBUTES
See attributes(5) for descriptions of the following attributes: +-----------------------------+-----------------------------+ | ATTRIBUTE TYPE | ATTRIBUTE VALUE | +-----------------------------+-----------------------------+ |Architecture |SPARC | +-----------------------------+-----------------------------+ SEE ALSO
ses(7D), ioctl(9E) SunOS 5.11 27 Mar 1997 sesio(7I)
Man Page