Intro(5) Standards, Environments, and Macros Intro(5)
Intro, intro - introduction to miscellany
Among the topics presented in this section are:
Standards The POSIX (IEEE) Standards and the X/Open Specifications are described on
the standards page.
Environments The user environment (environ), the subset of the user environment that
depends on language and cultural conventions (locale), the large file com-
pilation environment (lfcompile), and the transitional compilation envi-
ronment (lfcompile64) are described.
Macros The macros to format Reference Manual pages (man and mansun) as well as
other text format macros (me, mm, and ms) are described.
Characters Tables of character sets (ascii, charmap, eqnchar, and iconv), file format
notation (formats), file name pattern matching (fnmatch), and regular
expressions (regex and regexp) are presented.
Sun Microsystems, Inc. gratefully acknowledges The Open Group for permission to reproduce
portions of its copyrighted documentation. Original documentation from The Open Group can
be obtained online at http://www.opengroup.org/bookstore/.
The Institute of Electrical and Electronics Engineers and The Open Group, have given us
permission to reprint portions of their documentation.
In the following statement, the phrase ``this text'' refers to portions of the system doc-
Portions of this text are reprinted and reproduced in electronic form in the SunOS Refer-
ence Manual, from IEEE Std 1003.1, 2004 Edition, Standard for Information Technology --
Portable Operating System Interface (POSIX), The Open Group Base Specifications Issue 6,
Copyright (C) 2001-2004 by the Institute of Electrical and Electronics Engineers, Inc and
The Open Group. In the event of any discrepancy between these versions and the original
IEEE and The Open Group Standard, the original IEEE and The Open Group Standard is the
referee document. The original Standard can be obtained online at http://www.open-
This notice shall appear on any product containing this material.
SunOS 5.11 17 Nov 2008 Intro(5)