mddb.cf(4) File Formats mddb.cf(4)
mddb.cf - metadevice state database replica locations
The /etc/lvm/mddb.cf file is created when the metadb(1M) command is invoked. You should
never directly edit this file.
The file /etc/lvm/mddb.cf is used by the metainit(1M) command to find the locations of the
metadevice state databases replicas. The metadb command creates the file and updates it
each time it is run. Similar information is entered in the /kernel/drv/md.conf file.
Each metadevice state database replica has a unique entry in the /etc/lvm/mddb.cf file.
Each entry contains the driver and minor unit numbers associated with the block physical
device where a replica is stored. Each entry also contains the block number of the master
block, which contains a list of all other blocks in the replica.
Entries in the /etc/lvm/mddb.cf file are of the form: driver_name minor_t daddr_t check-
sum where driver_name and minor_t represent the device number of the physical device stor-
ing this replica. daddr_t is the disk block address. checksum is used to make certain the
entry has not been corrupted. A pound sign (#) introduces a comment.
Example 1 Sample File
The following example shows a mddb.cf file.
#metadevice database location file do not hand edit
#driver minor_t daddr_t device id checksum
sd 152 16 id1,sd@SSEAGATE_JDD288110MC9LH/a -2613
In the example above, the value for daddr_t indicates that the offset from the start of a
given partition is 16 disk blocks from the start of that partition.
mdmonitord(1M), metaclear(1M), metadb(1M), metadetach(1M), metahs(1M), metainit(1M),
metaoffline(1M), metaonline(1M), metaparam(1M), metarecover(1M), metarename(1M), metare-
place(1M), metaroot(1M), metassist(1M), metaset(1M), metastat(1M), metasync(1M), metat-
tach(1M), md.cf(4), md.tab(4), attributes(5), md(7D)
Solaris Volume Manager Administration Guide
SunOS 5.11 8 Aug 2003 mddb.cf(4)