depend(4) File Formats depend(4)
depend - software dependencies file
depend is an ASCII file used to specify information concerning software dependencies for a
particular package. The file is created by a software developer.
Each entry in the depend file describes a single software package. The instance of the
package is described after the entry line by giving the package architecture and/or ver-
sion. The format of each entry and subsequent instance definition is:
type pkg name
The fields are:
type Defines the dependency type. Must be one of the following characters:
P Indicates a prerequisite for installation; for example, the refer-
enced package or versions must be installed.
I Implies that the existence of the indicated package or version is
R Indicates a reverse dependency. Instead of defining the package's
own dependencies, this designates that another package depends on
this one. This type should be used only when an old package does not
have a depend file, but relies on the newer package nonetheless.
Therefore, the present package should not be removed if the desig-
nated old package is still on the system since, if it is removed,
the old package will no longer work.
pkg Indicates the package abbreviation.
name Specifies the full package name.
(arch)version Specifies a particular instance of the software. A version name cannot
begin with a left parenthesis. The instance specifications, both (arch)
and version, are completely optional, but each (arch)version pair must
begin on a new line that begins with white space. A null version set
equates to any version of the indicated package.
Example 1 Sample of depend file
Here are the contents of a sample depend file, for the SUNWftpr (FTP Server) package,
stored in /var/sadm/pkg/SUNWftpr/install:
P SUNWcar Core Architecture, (Root)
P SUNWkvm Core Architecture, (Kvm)
P SUNWcsr Core Solaris, (Root)
P SUNWcsu Core Solaris, (Usr)
P SUNWcsd Core Solaris Devices
P SUNWcsl Core Solaris Libraries
R SUNWftpu FTP Server, (Usr)
Application Packaging Developer's Guide
SunOS 5.11 4 Oct 1996 depend(4)