sysidtool(1M) System Administration Commands sysidtool(1M)
sysidtool, sysidnet, sysidns, sysidsys, sysidroot, sysidpm, sysidnfs4, sysidkbd - system configuration
sysidtool is a suite of programs that configure a new system, or one that has been unconfigured with sys-unconfig(1M). The sysidtool pro-
grams run automatically at system installation, or during the first boot after a machine has been successfully unconfigured.
These programs have no effect except at such times, and should never be run manually.
The sysidtool programs set up the appropriate information in the machine's configuration files, in the kernel, and on the machine's network
interface. The following list shows the available commands and the information for which each of the commands lists.
sysidnet: network configuration
Machine's default locale. Machine's console type. Machine's host name. Machine's IP address.
sysidns: name service configuration
Name service choice: NIS, NIS+, DNS, LDAP, or none. Machine's IP subnet mask (if no NIS/NIS+ server can automatically be located on the
machine's sub-network. Domain name for chosen name service. Hostname and IP address of name server(s). DNS search list (DNS name ser-
sysidsys: miscellaneous system configuration
Machine's IP subnet mask (if an NIS/NIS+ server was automatically located on the machine's sub-network). Machine's time zone. Date and
sysidroot: control superuser information
Machine's root password.
sysidpm: power management configuration
Auto-shutdown confirmation if the system is Energystar-V2 compliant, that is, a new system model shipped after October 1, 1995.
sysidnfs4: NFSv4 domain configuration
Domain name to be used by NFSv4 client(s) and server(s) to transmit user and group id's as strings of the general form
sysidkbd: keyboard layout configuration
The corresponding keytable is loaded into the kernel according to the configured keyboard layout.
sysidconfig: host- or platform-specific configuration
This command controls specification and execution of custom configuration applications that can be specified for a particular host or a
particular platform. See sysidconfig(1M).
The sysidtool programs attempt to obtain system configuration information from various name service databases, for example, NIS, or from
the sysidcfg(4) file, and you are prompted to provide the information if it cannot be found. However, you can avoid one or more of the
prompts by preconfiguring the appropriate configuration information in the name service databases or in the sysidcfg(4) file.
To preconfigure the information in the name service databases, you must use the name service commands or the Solstice AdminSuite tools. See
for more details about how to preconfigure the system configuration information.
The machine's configuration information is set up in its /etc and /var files.
If a system has more than one network interface, you can use sysidtool to configure all interfaces on the system.
You cannot use the name service databases or the sysidcfg(4) file to suppress the Power Management configuration prompt. However, you can
suppress it by creating either the /autoshutdown or /noautoshutdown file before installation reboot. Accordingly, the auto-shutdown feature
is silently configured. The /autoshutdown or /noautoshutdown files are removed by sysidpm before it exits.
sysidnfs4 installs the /etc/.NFS4inst_state.domain file upon the successful configuration of the NFSv4 domain name. If this file is present
during system reboot, the sysidnfs4 program is run but no prompts are displayed. The suppression of prompts is intended for system
upgrades, in which a system configuration typically stays unchanged. The stability level of this interface is obsolete
sysidkbd prompts for the keyboards with zero-bCountryCode and then sets the keyboard layout string in the /etc/default/kbd file. If the
sysidkbd gets the valid keyboard layout string, the string will be set into the entry "LAYOUT=" in the file.
/etc/passwd password file. See passwd(4).
/etc/shadow shadow password file. See shadow(4).
/etc/power.conf Power Management configuration file. See power.conf(4).
/etc/.PM_RECONFIGURE If this file is present during system reboot, the sysidpm program is run. This file is removed by sysidpm.
See attributes(5) for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Availability |SUNWadmap, SUNWpmu |
powerd(1M), sys-unconfig(1M), sysidconfig(1M), passwd(4), power.conf(4), shadow(4), sysidcfg(4), attributes(5)
NIS+ might not be supported in future releases of the Solaris Operating system. Tools to aid the migration from NIS+ to LDAP are available
in the current Solaris release. For more information, visit http://www.sun.com/directory/nisplus/transition.html.
SunOS 5.11 28 Nov 2006 sysidtool(1M)