in.talkd(1M) System Administration Commands in.talkd(1M)NAME
in.talkd, talkd - server for talk program
talkd is a server used by the talk(1) program. It listens at the UDP port indicated in the ``talk'' service description; see services(4).
The actual conversation takes place on a TCP connection that is established by negotiation between the two machines involved.
See attributes(5) for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Availability |SUNWrcmds |
SEE ALSO svcs(1), talk(1), inetadm(1M), inetd(1M), svcadm(1M), services(4), attributes(5), smf(5)NOTES
The protocol is architecture dependent.
The in.talkd service is managed by the service management facility, smf(5), under the service identifier:
Administrative actions on this service, such as enabling, disabling, or requesting restart, can be performed using svcadm(1M). Responsibil-
ity for initiating and restarting this service is delegated to inetd(1M). Use inetadm(1M) to make configuration changes and to view config-
uration information for this service. The service's status can be queried using the svcs(1) command.
SunOS 5.11 31 Jul 2004 in.talkd(1M)
Check Out this Related Man Page
talkd(8) System Manager's Manual talkd(8)NAME
talkd, ntalkd - The remote communications server for the talk command
The talkd server notifies a user or callee when a client or caller wants to initiate a conversation. The talkd daemon sets up the conver-
sation if the callee accepts the invitation. The caller initiates a conversation by executing the talk command and specifying the callee.
The callee accepts the invitation by executing the talk command specifying the caller.
The talkd daemon listens at a socket for a LOOK_UP request from a local or remote talk client. On receiving a LOOK_UP request, talkd scans
its internal invitation table for an entry that pairs the client (the local or remote talk process) with a caller.
If an entry exists in the talkd daemon's international invitation table, the talkd daemon assumes that the client process is the callee.
The talkd daemon returns the appropriate rendezvous address to the talk process for the callee. The callee process then establishes a
stream connection with the caller process.
If an entry does not exist in the invitation table, the talkd daemon assumes that the client process is the caller. The talkd daemon then
receives the client process's ANNOUNCE request. When talkd receives the ANNOUNCE request, talkd broadcasts an invitation on the console of
the remote host where the callee is logged in, unless the caller specifies a particular tty. At approximately 1-minute intervals, talkd
rebroadcasts the invitation until either the invitation is answered by the callee or the call is canceled by the caller.
Debugging messages are sent to syslogd(8). For further information on the files used by this daemon, see the syslogd command.
Specifies the command path Defines Internet socket assignments Contains data about users who are currently logged in
The Tru64 UNIX version of talkd uses the talk 4.3BSD protocol. This command is sometimes referred to as ntalkd. It is not compatible with
4.2BSD versions of talk.
Commands: inetd(8), syslogd(8), talk(1) delim off
Hi , I need help, today I restarted the server, when the machine was up, it had been to writte in the file osmlog that :
"inetd: talk/udp: bind: Address already in use"
This message appears in ten minutes every time. Why ?
Thanks. (6 Replies)
Note, this does not refer to posters who use English as a second language.
I must admit I dislike posts which appear to have been relayed by somebody texting while driving and wearing a straight-jacket.
Perhaps I am an old conservative but I find them both hard to read and also makes me more... (4 Replies)
The UNIX Forums have many users, thanks to you. We will be upgrading the server soon, to make more processing room for all the users every day.
In the meantime (while waiting on the server upgrade) have limited the forum to disallow new connections when the load average is above 20; and... (9 Replies)
I want to write a script for netflow service
because my service doesnt send any packet to netflow walker (server).
Although the service is started but it does not send any packet to server until i restart the service
I want to write a script in order to restart the service... (7 Replies)
Hi! I would like to start creating a bridge for good old Unix talk program. This bridge would allow you to joinIRC-channel by using talk just for example. I have a couple of questions:
1. Are there any previous attempts or implementations creating Talk bridge?
2. Which version of the talk... (9 Replies)