format(1M) System Administration Commands format(1M)
format - disk partitioning and maintenance utility
format [-f command-file] [-l log-file] [-x data-file]
[-d disk-name] [-t disk-type] [-p partition-name]
[-s] [-m] [-M] [-e] [disk-list]
format enables you to format, label, repair, and analyze disks on your system. Unlike previous disk maintenance programs, format runs under
SunOS. Because there are limitations to what can be done to the system disk while the system is running, format is also supported within
the memory-resident system environment. For most applications, however, running format under SunOS is the more convenient approach.
format first uses the disk list defined in data-file if the -x option is used. format then checks for the FORMAT_PATH environment variable,
a colon-separated list of filenames and/or directories. In the case of a directory, format searches for a file named format.dat in that
directory; a filename should be an absolute pathname, and is used without change. format adds all disk and partition definitions in each
specified file to the working set. Multiple identical definitions are silently ignored. If FORMAT_PATH is not set, the path defaults to
disk-list is a list of disks in the form c?t?d? or /dev/rdsk/c?t?d?s?. With the latter form, shell wildcard specifications are supported.
For example, specifying /dev/rdsk/c2* causes format to work on all drives connected to controller c2 only. If no disk-list is specified,
format lists all the disks present in the system that can be administered by format.
Removable media devices are listed only when users execute format in expert mode (option -e). This feature is provided for backward compat-
ibility. Use rmformat(1) for rewritable removable media devices.
The following options are supported:
-d disk-name Specify which disk should be made current upon entry into the program. The disk is specified by its logical name (for
instance, -d c0t1d0). This can also be accomplished by specifying a single disk in the disk list.
-e Enable SCSI expert menu. Note this option is not recommended for casual use.
-f command-file Take command input from command-file rather than the standard input. The file must contain commands that appear just
as they would if they had been entered from the keyboard. With this option, format does not issue continue? prompts;
there is no need to specify y(es) or n(o) answers in the command-file. In non-interactive mode, format does not ini-
tially expect the input of a disk selection number. The user must specify the current working disk with the -d disk-
name option when format is invoked, or specify disk and the disk selection number in the command-file.
-l log-file Log a transcript of the format session to the indicated log-file, including the standard input, the standard output
and the standard error.
-m Enable extended messages. Provides more detailed information in the event of an error.
-M Enable extended and diagnostic messages. Provides extensive information on the state of a SCSI device's mode pages,
-p partition-name Specify the partition table for the disk which is current upon entry into the program. The table is specified by its
name as defined in the data file. This option can be used only if a disk is being made current, and its type is either
specified or available from the disk label.
-s Silent. Suppress all of the standard output. Error messages are still displayed. This is generally used in conjunction
with the -f option.
-t disk-type Specify the type of disk which is current upon entry into the program. A disk's type is specified by name in the data
file. This option can only be used if a disk is being made current as described above.
-x data-file Use the list of disks contained in data-file.
When you invoke format with no options or with the -e, -l, -m, -M, or -s options, the program displays a numbered list of available disks
and prompts you to specify a disk by list number. If the machine has more than 10 disks, press SPACE to see the next screenful of disks.
You can specify a disk by list number even if the disk is not displayed in the current screenful. For example, if the current screen shows
disks 11-20, you can enter 25 to specify the twenty-fifth disk on the list. If you enter a number for a disk that is not currently dis-
played, format prompts you to verify your selection. If you enter a number from the displayed list, format silently accepts your selection.
After you specify a disk, format displays its main menu. This menu enables you to perform the following tasks:
analyze Run read, write, compare tests, and data purge. The data purge function implements the National Computer Security Center Guide
to Understanding Data Remnance (NCSC-TG-025 version 2) Overwriting Algorithm. See NOTES.
backup Search for backup labels.
cache Enable, disable, and query the state of the write cache and read cache. This menu item only appears when format is invoked
with the -e option, and is only supported on SCSI devices..
current Display the device name, the disk geometry, and the pathname to the disk device.
defect Retrieve and print defect lists. This option is supported only on SCSI devices. IDE disks perform automatic defect management.
Upon using the defect option on an IDE disk, you receive the message:
Controller does not support defect management
or disk supports automatic defect management.
disk Choose the disk that will be used in subsequent operations (known as the current disk.)
fdisk Run the fdisk(1M) program to create a fdisk partition for Solaris software (x86 based systems only).
format Format and verify the current disk. This option is supported only on SCSI devices. IDE disks are pre-formatted by the manufac-
turer. Upon using the format option on an IDE disk, you receive the message:
Cannot format this drive. Please use your
manufacturer-supplied formatting utility.
inquiry Display the vendor, product name, and revision level of the current drive.
label Write a new label to the current disk.
partition Create and modify slices.
quit Exit the format menu.
repair Repair a specific block on the disk.
save Save new disk and slice information.
type Select (define) a disk type.
verify Read and display labels. Print information such as the number of cylinders, alternate cylinders, heads, sectors, and the par-
volname Label the disk with a new eight character volume name.
FORMAT_PATH a colon-separated list of filenames and/or directories of disk and partition definitions. If a directory is specified, for-
mat searches for the file format.dat in that directory.
/etc/format.dat default data file
See attributes(5) for descriptions of the following attributes:
| ATTRIBUTE TYPE | ATTRIBUTE VALUE |
|Availability |SUNWcsu |
fmthard(1M), prtvtoc(1M), rmformat(1), format.dat(4), attributes(5), sd(7D)
When the format function is selected to format the Maxtor 207MB disk, the following message displays:
Mode sense page(4) reports rpm value as 0, adjusting it to 3600
This is a drive bug that may also occur with older third party drives. The above message is not an error; the drive will still function
Cylinder 0 contains the partition table (disk label), which can be overwritten if used in a raw disk partition by third party software.
format supports writing EFI-compliant disk labels in order to support disks or LUNs with capacities greater than one terabyte. However,
care should be exercised since many software components, such as filesystems and volume managers, are still restricted to capacities of one
terabyte or less. See the System Administration Guide: Basic Administration for additional information.
By default, on an unlabeled disk, EFI labels will be written on disks larger than 2 TB. When format is invoked with the -e option, on writ-
ing the label, the label type can be chosen. Booting is not currently supported on a disk with an EFI label.
format provides a help facility you can use whenever format is expecting input. You can request help about what information is expected by
simply entering a question mark (?) and format prints a brief description of what type of input is needed. If you enter a ? at the menu
prompt, a list of available commands is displayed.
For SCSI disks, formatting is done with both Primary and Grown defects list by default. However, if only Primary list is extracted in
defect menu before formatting, formatting will be done with Primary list only.
Changing the state of the caches is only supported on SCSI devices, and not all SCSI devices support changing or saving the state of the
The NCSC-TG-025 algorithm for overwriting meets the DoD 5200.28-M (ADP Security Manual) Eraser Procedures specification. The NIST Guide-
lines for Media Sanitization (NIST SP 800-88) also reference this algorithm.
SunOS 5.11 25 Sep 2008 format(1M)