|Linux & Unix Commands - Search Man Pages
StartupItemContext(8) BSD System Manager's Manual StartupItemContext(8)
StartupItemContext -- Execute a program in StartupItem context
StartupItemContext [program [arguments]]
The StartupItemContext utility launches the specified program in StartupItem bootstrap con-
text. Each Darwin and Mac OS X login creates a unique bootstrap subset context to contain
login specific Mach port registrations with the bootstrap server. All such registrations
performed within the context of that subset are only visible to other processes within that
context or subsequent subsets of it. Therefore, a Mach port based service/daemon launched
within a login context will not be visible to other such contexts.
To override this, a root user can use the StartupItemContext utility to launch the program
within the same bootstrap context as all other StartupItems. All subsequent Mach port boot-
strap registrations perfomed by the program will be visible system-wide.
All bootstrap port lookups will also be resticted to the StartupItem context. The services
provided on a per-login basis (clipboard, etc...) will not be available to the program.
"Bootstrap Contexts Unleashed"
Darwin July 7, 2002 Darwin
All times are GMT -4. The time now is 08:39 PM.