StartupItemContext(8) BSD System Manager's Manual StartupItemContext(8)NAME
StartupItemContext -- Execute a program in StartupItem context
StartupItemContext [program [arguments]]
The StartupItemContext utility launches the specified program in StartupItem bootstrap context. Each Darwin and Mac OS X login creates a
unique bootstrap subset context to contain login specific Mach port registrations with the bootstrap server. All such registrations per-
formed within the context of that subset are only visible to other processes within that context or subsequent subsets of it. Therefore, a
Mach port based service/daemon launched within a login context will not be visible to other such contexts.
To override this, a root user can use the StartupItemContext utility to launch the program within the same bootstrap context as all other
StartupItems. All subsequent Mach port bootstrap registrations perfomed by the program will be visible system-wide.
All bootstrap port lookups will also be resticted to the StartupItem context. The services provided on a per-login basis (clipboard, etc...)
will not be available to the program.
SEE ALSO SystemStarter(8)mach_init(8)
"Bootstrap Contexts Unleashed"
Darwin July 7, 2002 Darwin
Check Out this Related Man Page
SystemStarter(8) BSD System Manager's Manual SystemStarter(8)NAME
SystemStarter -- Start, stop, and restart system services
SystemStarter [-gvxdDqn] [action [service]]
The SystemStarter utility is deprecated. System services should instead be described by a launchd.plist(5). See launchd(8) for more
details. The launchd utility is available on Mac OS X 10.4 and later.
In earlier versions of Mac OS X, the SystemStarter utility is used to start, stop, and restart the system services which are described in the
/Library/StartupItems/ and /System/Library/StartupItems/ paths.
The optional action argument specifies which action SystemStarter performs on the startup items. The optional service argument specifies
which startup items to perform the action on. If no service is specified, all startup items will be acted on; otherwise, only the item pro-
viding the service, any items it requires, or any items that depend on it will be acted on.
During boot SystemStarter is invoked by launchd(8) and is responsible for starting all startup items in an order that satisfies each item's
start start all items, or start the item that provides the specified service and all items providing services it requires.
stop stop all items, or stop the item that provides the specified service and all items that depend on it.
restart restart all items, or restart the item providing the specified service.
OPTIONS -g (ignored)
-v verbose (text mode) startup
-d print debugging output
-D print debugging output and dependencies
-q be quiet (disable debugging output)
-n don't actually perform action on items (no-run mode)
Unless an explicit call to ConsoleMessage is made, SystemStarter examines the exit status of the startup item scripts to determine the suc-
cess or failure of the services provided by that script.
/Library/StartupItems/ User-installed startup items.
/System/Library/StartupItems/ System-provided startup items.
SEE ALSO ConsoleMessage(8), launchd(8), launchd.plist(5), rc(8)HISTORY
The SystemStarter utility appeared in Darwin 1.0 and was extended in Darwin 6.0 to support partial startup and interprocess communication.
SystemStarter was deprecated by launchd(8) in Darwin 8.0.
Darwin April 12, 2002 Darwin