RTADVD(8) BSD System Manager's Manual RTADVD(8)
rtadvd -- router advertisement daemon
rtadvd [-dDfMRs] [-c configfile] interface ...
rtadvd sends router advertisement packets to the specified interfaces.
The program will daemonize itself on invocation. It will then send router advertisement
packets periodically, as well as in response to router solicitation messages sent by end
Router advertisements can be configured on a per-interface basis, as described in
If there is no configuration file entry for an interface, or if the configuration file does
not exist altogether, rtadvd sets all the parameters to their default values. In particu-
lar, rtadvd reads all the interface routes from the routing table and advertises them as on-
rtadvd also watches the routing table. By default, if an interface direct route is
added/deleted on an advertising interface and no static prefixes are specified by the con-
figuration file, rtadvd adds/deletes the corresponding prefix to/from its advertising list,
respectively. The -s option may be used to disable this behavior. Moreover, if the status
of an advertising interface changes, rtadvd will start or stop sending router advertisements
according to the latest status.
Basically, hosts MUST NOT send Router Advertisement messages at any time (RFC 2461, Section
6.2.3). However, it would sometimes be useful to allow hosts to advertise some parameters
such as prefix information and link MTU. Thus, rtadvd can be invoked if router lifetime is
explicitly set zero on every advertising interface.
The command line options are:
-c Specify an alternate location, configfile, for the configuration file. By default,
/etc/rtadvd.conf is used.
-d Print debugging information.
-D Even more debugging information is printed.
-f Foreground mode (useful when debugging).
-M Specify an interface to join the all-routers site-local multicast group. By
default, rtadvd tries to join the first advertising interface appeared in the com-
mand line. This option has meaning only with the -R option, which enables routing
renumbering protocol support.
-R Accept router renumbering requests. If you enable it, certain IPsec setup is sug-
gested for security reasons. On KAME-based systems, rrenumd(8) generates router
renumbering request packets. This option is currently disabled, and is ignored by
rtadvd with a warning message.
-s Do not add or delete prefixes dynamically. Only statically configured prefixes, if
any, will be advertised.
Upon receipt of signal SIGUSR1, rtadvd will dump the current internal state into
Use SIGTERM to kill rtadvd gracefully. In this case, rtadvd will transmit router advertise-
ment with router lifetime 0 to all the interfaces (in accordance with RFC2461 6.2.5).
The rtadvd utility exits 0 on success, and >0 if an error occurs.
/etc/rtadvd.conf The default configuration file.
/var/run/rtadvd.pid contains the pid of the currently running rtadvd.
/var/run/rtadvd.dump in which rtadvd dumps its internal state.
rtadvd.conf(5), rrenumd(8), rtsol(8)
The rtadvd command first appeared in WIDE Hydrangea IPv6 protocol stack kit.
There used to be some text that recommended users not to let rtadvd advertise Router Adver-
tisement messages on an upstream link to avoid undesirable icmp6(4) redirect messages. How-
ever, based on the later discussion in the IETF ipng working group, all routers should
rather advertise the messages regardless of the network topology, in order to ensure reacha-
BSD May 17, 1998 BSD