MTREE(8) BSD System Manager's Manual MTREE(8)
mtree -- map a directory hierarchy
mtree [-LPUcdeinqrux] [-f spec] [-K keywords] [-k keywords] [-p path] [-s seed]
The utility mtree compares the file hierarchy rooted in the current directory against a
specification read from the standard input. Messages are written to the standard output for
any files whose characteristics do not match the specifications, or which are missing from
either the file hierarchy or the specification.
The options are as follows:
-L Follow all symbolic links in the file hierarchy.
-P Don't follow symbolic links in the file hierarchy, instead consider the symbolic link
itself in any comparisons. This is the default.
-U Modify the owner, group and permissions of existing files to match the specification
and create any missing directories or symbolic links. User, group and permissions
must all be specified for missing directories to be created. Corrected mismatches are
not considered errors.
-c Print a specification for the file hierarchy to the standard output.
-d Ignore everything except directory type files.
-e Don't complain about files that are in the file hierarchy, but not in the specifica-
-i Indent the output 4 spaces each time a directory level is descended when create a
specification with the -c option. This does not affect either the /set statements or
the comment before each directory. It does however affect the comment before the
close of each directory.
-n Do not emit pathname comments when creating a specification. Normally a comment is
emitted before each directory and before the close of that directory when using the -c
-q Quiet mode. Do not complain when a ``missing'' directory cannot be created because it
is already exists. This occurs when the directory is a symbolic link.
-r Remove any files in the file hierarchy that are not described in the specification.
-u Same as -U except a status of 2 is returned if the file hierarchy did not match the
-x Don't descend below mount points in the file hierarchy.
Read the specification from file, instead of from the standard input.
Add the specified (whitespace or comma separated) keywords to the current set of key-
Use the ``type'' keyword plus the specified (whitespace or comma separated) keywords
instead of the current set of keywords.
Use the file hierarchy rooted in path, instead of the current directory.
Display a single checksum to the standard error output that represents all of the
files for which the keyword cksum was specified. The checksum is seeded with the
The specified file contains fnmatch(3) patterns matching files to be excluded from the
specification, one to a line. If the pattern contains a '/' character, it will be
matched against entire pathnames (relative to the starting directory); otherwise, it
will be matched against basenames only. No comments are allowed in the exclude-list
Specifications are mostly composed of ``keywords'', i.e. strings that that specify values
relating to files. No keywords have default values, and if a keyword has no value set, no
checks based on it are performed.
Currently supported keywords are as follows:
cksum The checksum of the file using the default algorithm specified by the cksum(1)
flags The file flags as a symbolic name. See chflags(1) for information on these
names. If no flags are to be set the string ``none'' may be used to override
the current default.
ignore Ignore any file hierarchy below this file.
gid The file group as a numeric value.
gname The file group as a symbolic name.
mode The current file's permissions as a numeric (octal) or symbolic value.
nlink The number of hard links the file is expected to have.
nochange Make sure this file or directory exists but otherwise ignore all attributes.
uid The file owner as a numeric value.
uname The file owner as a symbolic name.
size The size, in bytes, of the file.
link The file the symbolic link is expected to reference.
time The last modification time of the file.
type The type of the file; may be set to any one of the following:
block block special device
char character special device
file regular file
link symbolic link
The default set of keywords are flags, gid, mode, nlink, size, link, time, and uid.
There are four types of lines in a specification.
The first type of line sets a global value for a keyword, and consists of the string
``/set'' followed by whitespace, followed by sets of keyword/value pairs, separated by
whitespace. Keyword/value pairs consist of a keyword, followed by an equals sign (``=''),
followed by a value, without whitespace characters. Once a keyword has been set, its value
remains unchanged until either reset or unset.
The second type of line unsets keywords and consists of the string ``/unset'', followed by
whitespace, followed by one or more keywords, separated by whitespace.
The third type of line is a file specification and consists of a file name, followed by
whitespace, followed by zero or more whitespace separated keyword/value pairs. The file
name may be preceded by whitespace characters. The file name may contain any of the stan-
dard file name matching characters (``['', ``]'', ``?'' or ``*''), in which case files in
the hierarchy will be associated with the first pattern that they match.
Each of the keyword/value pairs consist of a keyword, followed by an equals sign (``=''),
followed by the keyword's value, without whitespace characters. These values override,
without changing, the global value of the corresponding keyword.
All paths are relative. Specifying a directory will cause subsequent files to be searched
for in that directory hierarchy. Which brings us to the last type of line in a specifica-
tion: a line containing only the string ``..'' causes the current directory path to ascend
Empty lines and lines whose first non-whitespace character is a hash mark (``#'') are
The mtree utility exits with a status of 0 on success, 1 if any error occurred, and 2 if the
file hierarchy did not match the specification. A status of 2 is converted to a status of 0
if the -U option is used.
/etc/mtree system specification directory
The mtree utility exits 0 on success, and >0 if an error occurs.
chflags(1), chgrp(1), chmod(1), cksum(1), stat(2), fts(3), chown(8)
The mtree utility appeared in 4.3BSD-Reno. The MD5 digest capability was added in
FreeBSD 2.1, in response to the widespread use of programs which can spoof cksum(1). The
SHA-1 and RIPEMD160 digests were added in FreeBSD 4.0, as new attacks have demonstrated
weaknesses in MD5. Support for file flags was added in FreeBSD 4.0, and mostly comes from
BSD February 26, 1999 BSD