IOALLOCCOUNT(8) BSD System Manager's Manual IOALLOCCOUNT(8)NAME
ioalloccount -- Summarize IOKit memory usage.
ioalloccount displays some accounting of memory allocated by IOKit allocators, including object instances, in the kernel. Useful for tracking
leaks. This information can also found in the Root of the IORegistry.
List allocations by type, with sample output.
Instance allocation = 000169f8 = 90 K
Container allocation = 0002793e = 158 K
IOMalloc allocation = 00011555 = 69 K
SEE ALSO ioalloccount(8), ioreg(8)Darwin February 29, 2000 Darwin
Check Out this Related Man Page
IOREG(8) BSD System Manager's Manual IOREG(8)NAME
ioreg -- show I/O Kit registry
ioreg [-b] [[-c class] [-l] [-n name]] [-p plane] [-s] [-S] [-w width] [-x]
ioreg displays the I/O Kit registry. The use of the -c, -l, or -n options cause ioreg to show the properties of objects matching the speci-
fied criteria. By default, ioreg does not show the properties of an object.
The options are as follows:
-b Show the object name in bold.
-c Show the object properties only if the object is, or derives from, the specified class.
-l Show the object properties.
-n Show the object properties only if the object has the specified name.
-p Traverse the registry over the specified plane. The default plane value is ``IOService''. The other planes, such as ``IODeviceTree'',
can be found under the ``IORegistryPlanes'' property of the root object (ioreg -n Root).
-s Show the object state (busy state, retain count). This is the default.
-S Don't show the object state (busy state, retain count).
-w Clip the output to the specified line width. The default width value is the current screen size. A value of 0 specifies an unlimited
-x Print numeric property values in hexadecimal.
Darwin January 1, 2000 Darwin
What is the point of this? Whenever I close my shell it appends to the history file without adding this. I have never seen it overwrite my history file.
# When the shell exits, append to the history file instead of overwriting it
shopt -s histappend (3 Replies)
I'm trying to delete a file with a weird name from within Terminal on a Mac.
It's a very old file (1992) with null characters in the name: ââWord FinderÂŽ Plusâ˘.
Here are some examples of what I've tried:
12FX009:5 dpontius$ ls
ââWord FinderÂŽ Plusâ˘
12FX009:5 dpontius$ rm... (29 Replies)