IFCONFIG(8) BSD System Manager's Manual IFCONFIG(8)
ifconfig -- configure network interface parameters
ifconfig [-L] [-m] interface [create] [address_family] [address[/prefixlength]
ifconfig interface destroy
ifconfig -a [-L] [-d] [-m] [-u] [address_family]
ifconfig -l [-d] [-u] [address_family]
ifconfig [-L] [-d] [-m] [-u]
Ifconfig is used to assign an address to a network interface and/or configure network inter-
face parameters. Ifconfig must be used at boot time to define the network address of each
interface present on a machine; it may also be used at a later time to redefine an inter-
face's address or other operating parameters.
The following options are available:
For the DARPA-Internet family, the address is either a host name present in the host
name data base, hosts(5), or a DARPA Internet address expressed in the Internet
standard ``dot notation''.
It is also possible to use the CIDR notation (also known as the slash notation) to
include the netmask. That is, one can specify an address like 192.168.0.1/16.
Specify the address family which affects interpretation of the remaining parameters.
Since an interface can receive transmissions in differing protocols with different
naming schemes, specifying the address family is recommended. The address or proto-
col families currently supported are ``inet'', ``inet6'',
Specify the address of the correspondent on the other end of a point to point link.
This parameter is a string of the form ``name unit'', for example, ``en0''.
The following parameters may be set with ifconfig:
add Another name for the alias parameter. Introduced for compatibility with BSD/OS.
alias Establish an additional network address for this interface. This is sometimes use-
ful when changing network numbers, and one wishes to accept packets addressed to the
old interface. If the address is on the same subnet as the first network address
for this interface, a netmask of 0xffffffff has to be specified.
-alias Remove the network address specified. This would be used if you incorrectly speci-
fied an alias, or it was no longer needed. If you have incorrectly set an NS
address having the side effect of specifying the host portion, removing all NS
addresses will allow you to respecify the host portion.
(Inet6 only.) Specify that the address configured is an anycast address. Based on
the current specification, only routers may configure anycast addresses. Anycast
address will not be used as source address of any of outgoing IPv6 packets.
arp Enable the use of the Address Resolution Protocol (arp(4)) in mapping between net-
work level addresses and link level addresses (default). This is currently imple-
mented for mapping between DARPA Internet addresses and IEEE 802 48-bit MAC
addresses (Ethernet, FDDI, and Token Ring addresses).
-arp Disable the use of the Address Resolution Protocol (arp(4)).
(Inet only.) Specify the address to use to represent broadcasts to the network.
The default broadcast address is the address with a host part of all 1's.
debug Enable driver dependent debugging code; usually, this turns on extra console error
-debug Disable driver dependent debugging code.
delete Another name for the -alias parameter.
down Mark an interface ``down''. When an interface is marked ``down'', the system will
not attempt to transmit messages through that interface. If possible, the interface
will be reset to disable reception as well. This action does not automatically dis-
able routes using the interface.
ether Another name for the lladdr parameter.
Set the link-level address on an interface. This can be used to e.g. set a new MAC
address on an ethernet interface, though the mechanism used is not ethernet-spe-
cific. The address addr is specified as a series of colon-separated hex digits. If
the interface is already up when this option is used, it will be briefly brought
down and then brought back up again in order to ensure that the receive filter in
the underlying ethernet hardware is properly reprogrammed.
If the driver supports the media selection system, set the media type of the inter-
face to type. Some interfaces support the mutually exclusive use of one of several
different physical media connectors. For example, a 10Mb/s Ethernet interface might
support the use of either AUI or twisted pair connectors. Setting the media type to
``10base5/AUI'' would change the currently active connector to the AUI port. Set-
ting it to ``10baseT/UTP'' would activate twisted pair. Refer to the interfaces'
driver specific documentation or man page for a complete list of the available
If the driver supports the media selection system, set the specified media options
on the interface. The opts argument is a comma delimited list of options to apply
to the interface. Refer to the interfaces' driver specific man page for a complete
list of available options.
If the driver supports the media selection system, disable the specified media
options on the interface.
tunnel src_addr dest_addr
(IP tunnel devices only.) Configure the physical source and destination address for
IP tunnel interfaces (gif(4)). The arguments src_addr and dest_addr are interpreted
as the outer source/destination for the encapsulating IPv4/IPv6 header.
Unconfigure the physical source and destination address for IP tunnel interfaces
previously configured with tunnel.
create Create the specified network pseudo-device. If the interface is given without a
unit number, try to create a new device with an arbitrary unit number. If creation
of an arbitrary device is sucessful, the new device name is printed to standard out-
Destroy the specified network pseudo-device.
plumb Another name for the create parameter. Included for Solaris compatibility.
Another name for the destroy parameter. Included for Solaris compatibility.
Set the routing metric of the interface to n, default 0. The routing metric is used
by the routing protocol (routed(8)). Higher metrics have the effect of making a
route less favorable; metrics are counted as addition hops to the destination net-
work or host.
mtu n Set the maximum transmission unit of the interface to n, default is interface spe-
cific. The MTU is used to limit the size of packets that are transmitted on an
interface. Not all interfaces support setting the MTU, and some interfaces have
(Inet only.) Specify how much of the address to reserve for subdividing networks
into sub-networks. The mask includes the network part of the local address and the
subnet part, which is taken from the host field of the address. The mask can be
specified as a single hexadecimal number with a leading '0x', with a dot-notation
Internet address, or with a pseudo-network name listed in the network table
networks(5). The mask contains 1's for the bit positions in the 32-bit address
which are to be used for the network and subnet parts, and 0's for the host part.
The mask should contain at least the standard network portion, and the subnet field
should be contiguous with the network portion.
The netmask can also be specified in CIDR notation after the address. See the
address option above for more information.
(Inet6 only.) Specify that len bits are reserved for subdividing networks into sub-
networks. The len must be integer, and for syntactical reason it must be between 0
to 128. It is almost always 64 under the current IPv6 assignment rule. If the
parameter is omitted, 64 is used.
remove Another name for the -alias parameter. Introduced for compatibility with BSD/OS.
Enable special processing of the link level of the interface. These three options
are interface specific in actual effect, however, they are in general used to select
special modes of operation. An example of this is to enable SLIP compression, or to
select the connector type for some Ethernet cards. Refer to the man page for the
specific driver for more information.
Disable special processing at the link level with the specified interface.
up Mark an interface ``up''. This may be used to enable an interface after an
``ifconfig down''. It happens automatically when setting the first address on an
interface. If the interface was reset when previously marked down, the hardware
will be re-initialized.
Ifconfig displays the current configuration for a network interface when no optional parame-
ters are supplied. If a protocol family is specified, ifconfig will report only the details
specific to that protocol family.
If the driver does supports the media selection system, the supported media list will be
included in the output.
If the -m flag is passed before an interface name, ifconfig will display all of the sup-
ported media for the specified interface. If -L flag is supplied, address lifetime is dis-
played for IPv6 addresses, as time offset string.
Optionally, the -a flag may be used instead of an interface name. This flag instructs
ifconfig to display information about all interfaces in the system. The -d flag limits this
to interfaces that are down, and -u limits this to interfaces that are up. When no argu-
ments are given, -a is implied.
The -l flag may be used to list all available interfaces on the system, with no other addi-
tional information. Use of this flag is mutually exclusive with all other flags and com-
mands, except for -d (only list interfaces that are down) and -u (only list interfaces that
Only the super-user may modify the configuration of a network interface.
The media selection system is relatively new and only some drivers support it (or have need
Messages indicating the specified interface does not exist, the requested address is
unknown, or the user is not privileged and tried to alter an interface's configuration.
IPv6 link-local addresses are required for several basic communication between IPv6 node.
If they are deleted by ifconfig manually, the kernel might show very strange behavior. So,
such manual deletions are strongly discouraged.
netstat(1), netintro(4), rc(8), routed(8)
The ifconfig command appeared in 4.2BSD.
BSD July 2, 2001 BSD