|Linux & Unix Commands - Search Man Pages
ConsoleMessage(8) BSD System Manager's Manual ConsoleMessage(8)
ConsoleMessage -- Send a message to SystemStarter
ConsoleMessage [-v] message
ConsoleMessage [-v] -S
ConsoleMessage [-v] -F
ConsoleMessage [-v] -s service
ConsoleMessage [-v] -f service
ConsoleMessage [-v] -q setting
ConsoleMessage [-v] -b path
ConsoleMessage [-v] -u
The ConsoleMessage utility may be used by startup item scripts to send messages to
SystemStarter (see SystemStarter(8)).
The default behavior is to send the specified message to SystemStarter to be displayed on
the console. SystemStarter will attempt to localize the string using the current startup
item's localization dictionaries.
ConsoleMessage may also be used to give feedback to SystemStarter indicating which services
provided by the startup item have succeeded or failed.
-v verbose mode (prints errors to stdout)
-S mark all services provided by this item as successful
-F mark all services provided by this item as failed
-s mark the service as successful
-f mark the service as failed
-q query SystemStarter for the value of the configuration variable setting (result
will be printed to stdout).
-b Tell SystemStarter to load the display bundle at the specified path
-u Tell SystemStarter to unload the current display bundle
When a service name is not specified, ConsoleMessage assumes its parent process identifica-
tion (see getppid(2)) is that of a startup item script, and uses that token to find the cor-
rect list of services provided by the current item. If the process calling ConsoleMessage is
not a startup item script, it is necessary to explicitly provide service names.
The ConsoleMessage utility appeared in Darwin 6.0
Darwin April 12, 2002 Darwin
All times are GMT -4. The time now is 01:49 PM.