idmapd.conf(5) BSD File Formats Manual idmapd.conf(5)NAME
idmapd.conf -- configuration file for idmapd, the NFSv4 ID <-> Name Mapper
Configuration file for idmapd, the NFSv4 ID <-> Name Mapper
The idmapd.conf configuration file has two sections, initiated by the strings [General] and [Mapping]. Each section may contain lines of the
variable = value
The variables allowed in the General section are Verbosity, Pipefs-Directory, and Domain, whose values have the same effect as the arguments
to the -v, -p, and -d commandline options, respectively. The variables allowed in the Mapping section are Nobody-User and Nobody-Group,
which have the same effect as the -U and -G commandline options.
An example /etc/idmapd.conf file:
Verbosity = 0
Pipefs-Directory = /var/lib/nfs/rpc_pipefs
Domain = localdomain
Nobody-User = nobody
Nobody-Group = nobody
SEE ALSO idmapd(8)AUTHORS
The idmapd software has been developed by Marius Aamodt Eriksen <firstname.lastname@example.org>.
BSD July 16, 2003 BSD
Check Out this Related Man Page
RPC.IDMAPD(8) BSD System Manager's Manual RPC.IDMAPD(8)NAME
rpc.idmapd -- NFSv4 ID <-> Name Mapper
rpc.idmapd [-v] [-f] [-p path] [-c path]
rpc.idmapd is the NFSv4 ID <-> name mapping daemon. It provides functionality to the NFSv4 kernel client and server, to which it communi-
cates via upcalls, by translating user and group IDs to names, and vice versa.
The options are as follows:
-v Increases the verbosity level (can be specified multiple times).
-f Runs rpc.idmapd in the foreground and prints all output to the terminal.
-p path Specifies the location of the RPC pipefs to be path. The default value is "/var/lib/nfs/rpc_pipefs".
-c path Use configuration file path.
-C Client-only: perform no idmapping for any NFS server, even if one is detected.
-S Server-only: perform no idmapping for any NFS client, even if one is detected.
rpc.idmapd -f -vvv
Runs rpc.idmapd printing all messages to console, and with a verbosity level of 3.
SEE ALSO idmapd.conf(5)AUTHORS
The rpc.idmapd software has been developed by Marius Aamodt Eriksen <email@example.com>.
BSD February 3, 2003 BSD
Is there a way to transfer my sudo password via ssh so that I can copy files remotely and pass them locally, so:
cat sudo-passwd-file|ssh -t firstname.lastname@example.org 'sudo find / -depth|cpio -oacv|gzip' > /path/to/dir/file.cpio.gz
I am in the process of a creating a script. Everytime I try and just... (16 Replies)
I have a problem with acl and nfs4 on centos.
On Slackware clients nfs4 fs mounted works
fine,acl (posix,not nfs acl) is respected.
On Centos 6.4 very strange thing..acl is not
working on nfs4.
nfsmount.conf and idmapd.conf are the same on all client
and kernel options on nfs acl are the... (1 Reply)
RHEL 7.1 client using autofs to mount a NIS map of home directories being exported by a Solaris 10x86 nfs server.
The owner and group are correct on the NFS server, but on the RHEL client, the owner and group end up being nobody nobody. The USERS and GROUPS are NIS maps as well. They are... (2 Replies)
I have 3 servers, rx2600, rx2600, and rx2660.
I have another x86 server running on Suse, and create a shared folder named /public
From 1 of the rx2600 server I can mount that shared folder :
intaqa:/>mount 10.1.2.82:/public /bkup
But from 2 others server I... (29 Replies)